概述
Buy Tickets
Description Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue… The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics. It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death! People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat. Input There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i (1 ≤ i ≤ N). For each i, the ranges and meanings ofPosi and Vali are as follows:
There no blank lines between test cases. Proceed to the end of input. Output For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue. Sample Input 4 0 77 1 51 1 33 2 69 4 0 20523 1 19243 1 3890 0 31492 Sample Output 77 33 69 51 31492 20523 3890 19243 Hint The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input. Source
POJ Monthly--2006.05.28, Zhu, Zeyuan
|
[Submit] [Go Back] [Status] [Discuss]
排队问题:
倒着插入保证插入的顺序
更新的时候
#pragma warning(disable:4786)//使命名长度不受限制
#pragma comment(linker, "/STACK:102400000,102400000")//手工开栈
#include <map>
#include <set>
#include <queue>
#include <cmath>
#include <stack>
#include <cctype>
#include <cstdio>
#include <cstring>
#include <stdlib.h>
#include <iostream>
#include <algorithm>
#define rd(x) scanf("%d",&x)
#define rd2(x,y) scanf("%d%d",&x,&y)
#define rds(x) scanf("%s",x)
#define rdc(x) scanf("%c",&x)
#define ll long long int
#define maxn 200100
#define mod 1000000007
#define INF 0x3f3f3f3f //int 最大值
#define FOR(i,f_start,f_end) for(int i=f_start;i<=f_end;++i)
#define MT(x,i) memset(x,i,sizeof(x))
#define PI acos(-1.0)
#define E exp(1)
using namespace std;
int num[maxn<<2],ans[maxn<<2];
int pos[maxn],val[maxn];
void creatTree(int st,int l,int r){
if(l==r){
num[st]=1;
return;
}
int m=(l+r)>>1;
int temp=st<<1;
creatTree(temp,l,m);
creatTree(temp+1,m+1,r);
num[st]=num[temp]+ num[temp+1];
}
void update(int pos,int val,int st,int l,int r){
if(l==r){
ans[l]=val;
num[st]=0;
return;
}
int temp=st<<1;
int m=(l+r)>>1;
if(num[temp]>=pos)update(pos,val,temp,l,m);
else update(pos-num[temp],val,temp+1,m+1,r);
num[st]=num[temp]+ num[temp+1];
}
int main(){
int n;
while(rd(n)!=EOF){
FOR(i,1,n)rd2(pos[i],val[i]);
creatTree(1,1,n);
MT(ans,0);
for(int i=n;i>0;i--)
update(pos[i]+1,val[i],1,1,n);
FOR(i,1,n)printf("%d ",ans[i]);
printf("n");
}
return 0;
}
/*
4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492
*/
最后
以上就是开放往事为你收集整理的POJ 2828 Buy Tickets 线段树的全部内容,希望文章能够帮你解决POJ 2828 Buy Tickets 线段树所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
发表评论 取消回复