我是靠谱客的博主 深情春天,最近开发中收集的这篇文章主要介绍大理石在哪,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Raju and Meena love to play with Marbles. They have got a lot of
marbles with numbers written on them. At the beginning, Raju would
place the marbles one after another in ascending order of the numbers
written on them. Then Meena would ask Raju to find the first marble
with a certain number. She would count 1...2...3. Raju gets one point
for correct answer, and Meena gets the point if Raju fails. After some
fixed number of trials the game ends and the player with maximum
points wins. Today it’s your chance to play as Raju. Being the smart
kid, you’d be taking the favor of a computer. But don’t underestimate
Meena, she had written a program to keep track how much time you’re
taking to give all the answers. So now you have to write a program,
which will help you in your role as Raju.

Input

There can be multiple test cases. Total no of test cases is less than 65.
 Each test case consists beginswith 2 integers: N the number of marbles 
and Q the number of queries Mina would make. The nextN lines would contain
 the numbers written on the N marbles. These marble numbers will not come
in any particular order. Following Q lines will have Q queries. Be assured,
 none of the input numbersare greater than 10000 and none of them are negative.
Input is terminated by a test case where N = 0 and Q = 0.

Output

For each test case output the serial number of the case.
For each of the queries, print one line of output. The format of this line will
 depend upon whetheror not the query number is written upon any of the marbles. 
The two different formats are described below:
? ‘x found at y’, if the firstmarble with number x was found at position y. 
Positions are numbered1, 2, . . . , N.


? ‘x not found’, if the marble with number x is not present.
Look at the output for sample input for details.


Sample Input


4 1
2
3
5
1
5
5 2
1
3
3
3
1
2
3
0 0


Sample Output
CASE# 1:
5 found at 4
CASE# 2:
2 not found

3 found at 3

#include<iostream>
#include<algorithm>
using namespace std;
const int maxn = 10000;
int main()
{
	int n, q, x, a[maxn], kase = 0;
	while (scanf("%d%d", &n, &q) == 2 && n!=0&&q!=0)
	{
		printf("CASE# %d:n", ++kase);
		for (int i = 0; i < n; i++)
			scanf("%d", &a[i]);
		sort(a, a + n);
		while (q--)
		{
			scanf("%d", &x);
			int p= lower_bound(a, a + n, x) - a;//再已排序数组a中寻找x
			if (a[p] == x) printf("%d found at %dn", x, p + 1);
			else printf("%d not foundn", x);
		}
	}
	return 0;
}


题解:有n个大理石,每个大理石上写了一个非负整数。首先把各数从小到大排序,然后回答Q个问题。

每个问题问是否有一个大理石写着某个整数x,如果是,还要回答哪个大理石上写着x。排序后大理石

从做到右编号为1-n

最后

以上就是深情春天为你收集整理的大理石在哪的全部内容,希望文章能够帮你解决大理石在哪所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(46)

评论列表共有 0 条评论

立即
投稿
返回
顶部