概述
Raju and Meena love to play with Marbles. They have got a lot ofmarbles with numbers written on them. At the beginning, Raju wouldplace the marbles one after another in ascending order of the numberswritten on them. Then Meena would ask Raju to find the first marblewith a certain number. She would count 1...2...3. Raju gets one pointfor correct answer, and Meena gets the point if Raju fails. After somefixed number of trials the game ends and the player with maximumpoints wins. Today it’s your chance to play as Raju. Being the smartkid, you’d be taking the favor of a computer. But don’t underestimateMeena, she had written a program to keep track how much time you’retaking to give all the answers. So now you have to write a program,which will help you in your role as Raju.
Input
There can be multiple test cases. Total no of test cases is less than 65. Each test case consists beginswith 2 integers: N the number of marbles and Q the number of queries Mina would make. The nextN lines would contain the numbers written on the N marbles. These marble numbers will not comein any particular order. Following Q lines will have Q queries. Be assured, none of the input numbersare greater than 10000 and none of them are negative.
Input is terminated by a test case where N = 0 and Q = 0.
Output
For each test case output the serial number of the case.
For each of the queries, print one line of output. The format of this line will depend upon whether
or not the query number is written upon any of the marbles. The two different formats are describedbelow:
• ‘x found at y’, if the first marble with number x was found at position y. Positions are numbered1,2,...,N.
• ‘x not found’, if the marble with number x is not present.Look at the output for sample input for details.
Sample Input
4 1
2
3
5
1
5
5 2
1
3
3
3
1
2
3
0 0
Sample Output
CASE# 1:
5 found at 4
CASE# 2:
2 not found
3 found at 3
考察内容:排序和查找
代码:
#include <iostream>
#include <vector>
#include <cstdio>
#include <algorithm>
using namespace std;
int main(int argc, const char * argv[]) {
int N, Q;
int T = 1;
while (scanf("%d %d", &N, &Q) && N && Q) {
vector<int> v; //定义vector容器,存储N个石头
for (int i = 0; i < N; i++) {
int temp;
scanf("%d", &temp); //把石头对应的标号插入容器尾部
v.push_back(temp);
}
//对容器内数据进行排序(默认从小到大的顺序排序)
sort(v.begin(), v.end());
printf("CASE# %d:n", T++);
for (int i = 0; i < Q; i++) {
int temp;
scanf("%d", &temp);
int j = 0;
//
for (j = 0; j < v.size(); j++) {
if (v[j] == temp) { //在容器内找到对应的数并输出
printf("%d found at %dn", v[j], j + 1);
break; //必须要添加break语句,因为题目只要求找到第一次出现的位置,不添加break语句,如果容器中有很个的话就会输出多个位置
}
}
if (j == v.size()) { //容器中不存在,输出找不到
printf("%d not foundn", temp);
}
}
}
return 0;
}
最后
以上就是文静帽子为你收集整理的Where is the Marble?的全部内容,希望文章能够帮你解决Where is the Marble?所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
发表评论 取消回复