我是靠谱客的博主 贤惠缘分,最近开发中收集的这篇文章主要介绍HDU——Queuing,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Problem Description
Queues and Priority Queues are data structures which are known to most computer scientists. The Queue occurs often in our daily life. There are many people lined up at the lunch time.

  Now we define that ‘f’ is short for female and ‘m’ is short for male. If the queue’s length is L, then there are 2 L numbers of queues. For example, if L = 2, then they are ff, mm, fm, mf . If there exists a subqueue as fmf or fff, we call it O-queue else it is a E-queue.
Your task is to calculate the number of E-queues mod M with length L by writing a program.
 

Input
Input a length L (0 <= L <= 10 6) and M.
 

Output
Output K mod M(1 <= M <= 30) where K is the number of E-queues with length L.
 

Sample Input
  
  
3 8 4 7 4 8
 

Sample Output
  
  
6 2 1
 
#include <stdio.h>
#define N 1000001
#define M 30

char node[N][M];

void init()
{
    int i,j;
    for(i=1;i<=M;i++)
    {
        node[1][i]=2%i;
        node[2][i]=4%i;
        node[3][i]=6%i;
        node[4][i]=9%i;
        for (j=5;j<=N;j++)
        {
            node[j][i]=(node[j-1][i]+node[j-3][i]+node[j-4][i])%i;
        }
    }
}

int main()
{
    init();
    int n,m;
    while (~scanf("%d%d",&n,&m))
    {
        printf("%dn",node[n][m]);
    }
    return 0;
}

最后

以上就是贤惠缘分为你收集整理的HDU——Queuing的全部内容,希望文章能够帮你解决HDU——Queuing所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(48)

评论列表共有 0 条评论

立即
投稿
返回
顶部