我是靠谱客的博主 难过裙子,最近开发中收集的这篇文章主要介绍hdoj 2604 Queuing,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

 

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6110    Accepted Submission(s): 2661

 

Problem Description

Queues and Priority Queues are data structures which are known to most computer scientists. The Queue occurs often in our daily life. There are many people lined up at the lunch time. 


  Now we define that ‘f’ is short for female and ‘m’ is short for male. If the queue’s length is L, then there are 2L numbers of queues. For example, if L = 2, then they are ff, mm, fm, mf . If there exists a subqueue as fmf or fff, we call it O-queue else it is a E-queue.
Your task is to calculate the number of E-queues mod M with length L by writing a program.

 

Input

Input a length L (0 <= L <= 10 6) and M.

 

Output

Output K mod M(1 <= M <= 30) where K is the number of E-queues with length L.

 

 

Sample Input

3 8 4 7 4 8

 

Sample Output

6 2 1

题目解析:

这道题目的关键在于对这个队列的结尾进行建模。从L=2 开始进行讨论,如果要是E队列,若原先结尾为ff,可以变化为fm,而原先结尾为fm, 可以变化为mm,原先结尾为mf, 可以变化为ff和fm,原先结尾为mm,可以变化为mf和mm。因此,可以构建一个状态转移矩阵。而初始状态L=2的时候,ff = fm = mf = mm = 1个,因此,通过快速幂的方法,可以得到任意(L>2)时候的结尾为ff,fm,mf和mm的序列的个数,最后求和即可。

 

#include <bits/stdc++.h>

using namespace std;
using ll = long long;
const int INF = 2e9;
const int MAXN = 1e6;
#define REP(i, s, k) for(int i = s; i< k; i++)

int MOD;
struct matrix{
 int n;
 vector<vector<int> > M;
 matrix(int n){
  this->n = n;
  M.resize(n, vector<int>(n, 0)); 
 }
 void eye(){for(int i = 0; i < n; i++) M[i][i] = 1;}
 
 friend matrix operator *(matrix A, matrix B){
  int n = A.n; matrix res(n);
  REP(i, 0, n) REP(j,0,n){
    if(A.M[i][j] == 0) continue;
    REP(k, 0, n) res.M[i][k] = (res.M[i][k] + A.M[i][j] * B.M[j][k] % MOD) % MOD;
  }
  return res;
 }

};

inline matrix qp(matrix A, int p){
  matrix res(4); res.eye();
  for(; p; p >>=1, A=A*A){
    if(p&1) res = res * A;
  } 
  return res;
}

inline int qp(int A, int p){
  int res = 1;
  for(; p; p >>=1, A = (A * A) % MOD){
    if(p & 1) res  = (res + A) % MOD;
  } 
  return res;
}

signed main(){
  int L, M;
  while(~scanf("%d %d", &L, &M)){
    MOD = M;
    if(L <= 2) printf("%dn", pow(2, L));
    matrix m(4); m.M[0][1] = m.M[1][3] = m.M[2][0] = m.M[2][1] = m.M[3][2] = m.M[3][3] = 1;
    m = qp(m, L-2);  
    int ans = 0;
    for(auto v: m.M) for(auto e: v) ans += e;
    ans %= MOD;
    printf("%dn", ans);
  }
  return 0;
}

 

最后

以上就是难过裙子为你收集整理的hdoj 2604 Queuing的全部内容,希望文章能够帮你解决hdoj 2604 Queuing所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(54)

评论列表共有 0 条评论

立即
投稿
返回
顶部