概述
Problem Description
There are many lamps in a line. All of them are off at first. A series of operations are carried out on these lamps. On the i-th operation, the lamps whose numbers are the multiple of i change the condition ( on to off and off to on ).
Input
Each test case contains only a number n ( 0< n<= 10^5) in a line.
Output
Output the condition of the n-th lamp after infinity operations ( 0 - off, 1 - on ).
Sample Input
1 5
Sample Output
1 0Consider the second test case: The initial condition : 0 0 0 0 0 … After the first operation : 1 1 1 1 1 … After the second operation : 1 0 1 0 1 … After the third operation : 1 0 0 0 1 … After the fourth operation : 1 0 0 1 1 … After the fifth operation : 1 0 0 1 0 … The later operations cannot change the condition of the fifth lamp any more. So the answer is 0.Hinthint
Author
LL
C语言AC代码
#include<stdio.h>
#include<math.h>
int main()
{
int n;
double t;
while(scanf("%d",&n)!=EOF)
{
t=sqrt(n*1.0);
if(t==(int)t)
printf("1n");
else
printf("0n");
}
return 0;
}
思路:1 模拟所有情况,超时
2
n的
的状态由n的约数个数决定。奇数时,开启,偶数时,关闭。
3 约数的个数为奇数时,n为平方数(平方数的两个约数相同),由此,判断n是否为平 方数即可。
最后
以上就是大胆羊为你收集整理的hdu2053 Switch Game(C语言)的全部内容,希望文章能够帮你解决hdu2053 Switch Game(C语言)所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
发表评论 取消回复