概述
Calculation
Assume that f(0) = 1 and 0^0=1. f(n) = (n%10)^f(n/10) for all n bigger than zero. Please calculate f(n)%m. (2 ≤ n , m ≤ 10^9, x^y means the y th power of x).
Input
The first line contains a single positive integer T. which is the number of test cases. T lines follows.Each case consists of one line containing two positive integers n and m.
Output
One integer indicating the value of f(n)%m.
Sample Input
2
24 20
25 20
Sample Output
16
5
题意:
让求公式 f(n)=(n%10)f(n10)%m f ( n ) = ( n % 10 ) f ( n 10 ) % m
分析:
很明显 f(n10) f ( n 10 ) 可能会很大,因此我们需要降幂,因为m不一定是素数因此不能用费马小定理降幂,只能用欧拉函数降幂
ax(mod m)=ax mod ϕ(m)+ϕ(m)(mod m) a x ( m o d m ) = a x m o d ϕ ( m ) + ϕ ( m ) ( m o d m )
注意在求x的时候,实际上是是通过递归用快速幂求出来的,因此快速幂的时候一定要取模再加模,否则不对我他妈。。坑了我一上午wa了11发
code:
#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
ll Euler(ll n){
ll res = n,a = n;
for(ll i = 2; i * i <= a; i++){
if(a % i == 0){
res = res / i * (i - 1);
while(a % i == 0) a /= i;
}
}
if(a > 1) res = res / a * (a - 1);
return res;
}
ll q_pow(ll a,ll b,ll mod){
ll ans = 1;
while(b){
if(b & 1){
ans = ans * a;
if(ans > mod) ans = ans % mod + mod;//注意!!必须加模
}
a = a * a;
if(a > mod) a = a % mod + mod;//注意!!必须加模
b >>= 1;
}
return ans;
}
ll f(ll n,ll m){
if(n < 10) return n;
ll phi = Euler(m);
ll t = f(n/10,phi),ans;
ans = q_pow(n%10,t,m);
return ans;
}
int main(){
int t;
scanf("%d",&t);
while(t--){
ll n,m;
scanf("%lld%lld",&n,&m);
printf("%lldn",f(n,m)%m);
}
return 0;
}
最后
以上就是生动大侠为你收集整理的hdu 2837 Calculation(指数循环节+欧拉函数)Calculation的全部内容,希望文章能够帮你解决hdu 2837 Calculation(指数循环节+欧拉函数)Calculation所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
发表评论 取消回复