我是靠谱客的博主 霸气月饼,最近开发中收集的这篇文章主要介绍C语言 数据结构之二叉树 数据结构实验之二叉树二:遍历二叉树,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

数据结构实验之二叉树二:遍历二叉树
Time Limit: 1000MS Memory Limit: 65536KB
Submit Statistic
Problem Description

已知二叉树的一个按先序遍历输入的字符序列,如abc,,de,g,,f,,, (其中,表示空结点)。请建立二叉树并按中序和后序的方式遍历该二叉树。
Input

连续输入多组数据,每组数据输入一个长度小于50个字符的字符串。
Output

每组输入数据对应输出2行:
第1行输出中序遍历序列;
第2行输出后序遍历序列。

Example Input

abc,,de,g,,f,,,
Example Output

cbegdfa
cgefdba

#include<stdio.h>
#include<stdlib.h>
struct node
{
    char data;
    struct node *l, *r;
};
char a[51];
int top;
struct node *creat()
{
    struct node *root;
    top++;
    if(a[top] == ',')
        root = NULL;
    else
    {
        root = (struct node*) malloc(sizeof(struct node));
        root->data = a[top];
        root->l = creat();
        root->r = creat();
    }
    return root;
};
void zhongxu(struct node *root)
{
    if(root)
    {
        zhongxu(root -> l);
        printf("%c", root -> data);
        zhongxu(root -> r);
    }
}
void houxu(struct node *root)
{
    if(root)
    {
        houxu(root -> l);
        houxu(root -> r);
        printf("%c", root -> data);
    }
}
int main()
{
    while(~scanf("%s", a))
    {
        top = -1;
        struct node *root;
        root = creat();
        zhongxu(root);
        printf("n");
        houxu(root);
        printf("n");
    }
    return 0;
}

最后

以上就是霸气月饼为你收集整理的C语言 数据结构之二叉树 数据结构实验之二叉树二:遍历二叉树的全部内容,希望文章能够帮你解决C语言 数据结构之二叉树 数据结构实验之二叉树二:遍历二叉树所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(66)

评论列表共有 0 条评论

立即
投稿
返回
顶部