我是靠谱客的博主 超级斑马,最近开发中收集的这篇文章主要介绍数据结构实验之二叉树五:层序遍历,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

数据结构实验之二叉树五:层序遍历

Time Limit: 1000MS Memory Limit: 65536KB

Submit Statistic

Problem Description


已知一个按先序输入的字符序列,如abd,,eg,,,cf,,,(其中,表示空结点)。请建立二叉树并求二叉树的层次遍历序列。

Input

输入数据有多行,第一行是一个整数t (t<1000),代表有t行测试数据。每行是一个长度小于50个字符的字符串。

Output

输出二叉树的层次遍历序列。

Example Input

2
abd,,eg,,,cf,,,
xnl,,i,,u,,

Example Output

abcdefg
xnuli

Hint



Author

xam



#include<stdio.h>
#include<stdlib.h>
#include<string.h>
typedef struct node
{
    char data;
    struct node *lc, *rc;
}*Tree;
void creat(Tree &T);
void OutPut(Tree T);
Tree b[55];
char a[55];
int i, j, k;
int main()
{
    int t;
    Tree T;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%s", a);
        i = -1;
        k = 0;
        j = 0;
        creat(T);
        OutPut(T);
        printf("n");
    }
    return 0;
}

void creat(Tree &T)
{
    char c;
    c = a[++i];
    if(c == ',')
        T = NULL;
    else
    {
        T = (Tree)malloc(sizeof(struct node));  //重中之重
        T->data = c;
        creat(T->lc);
        creat(T->rc);
    }
}

void OutPut(Tree T)
{
    if(T)
    {
        b[j++] = T;
        while(k < j)
        {
            if(b[k]->lc)
            {
                b[j++] = b[k]->lc;
            }
            if(b[k]->rc)
            {
                b[j++] = b[k]->rc;
            }
            printf("%c", b[k++]->data);
        }
    }
}


最后

以上就是超级斑马为你收集整理的数据结构实验之二叉树五:层序遍历的全部内容,希望文章能够帮你解决数据结构实验之二叉树五:层序遍历所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(47)

评论列表共有 0 条评论

立即
投稿
返回
顶部