概述
这里是题目( • ̀ω•́ )✧
The Suspects
Time Limit: 1000MS Memory Limit: 20000K
Total Submissions: 40593 Accepted: 19592
Description
Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input
The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output
For each case, output the number of suspects in one line.
Sample Input
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0
Sample Output
4
1
1
Source
Asia Kaohsiung 2003
#include<stdio.h>
const int max=30005;
int par[max],vis[max];
int find(int x)
{
if(x!=par[x])
return par[x]=find(par[x]);
else return x;
}
void merge(int xx,int yy)
{
int fx=find(xx);
int fy=find(yy);
if(fx==fy) return ;
if(vis[fx]<vis[fy]) {
par[fx]=fy;
vis[fy]=vis[fy]+vis[fx];
}
else {
par[fy]=fx;
vis[fx]=vis[fy]+vis[fx];
}
}
int main()
{
int m,n,k,t,r;
while(~scanf("%d%d",&n,&m))
{
if(m==0&&n==0) break;
for(int i=0;i<=max;i++)
par[i]=i,vis[i]=1;
for(int i=0;i<m;i++)
{
scanf("%d",&k);
scanf("%d",&t);
for(int j=0;j<k-1;j++)
{
scanf("%d",&r);
merge(t,r);
}
}
printf("%dn",vis[par[0]]); //与0同一根节点的就是一组的
}
return 0;
}
最后
以上就是魁梧小海豚为你收集整理的【POJ1611】The Suspects(并查集)的全部内容,希望文章能够帮你解决【POJ1611】The Suspects(并查集)所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
发表评论 取消回复