概述
1.编程题 - 字符串逆序
使用C++新特性编写程序,输入一个字符串,按单词将该字符串逆序输出,该字符串最多包含20个单词,为了简化问题,字符串中不包含标点符号。
提示:可用c++中string类数组
如:
输入:XIAN JIAOTONG UNIVERSITY
输出:UNIVERSITY JIAOTONG XIAN
样例输入:
XIAN JIAOTONG UNIVERSITY
样例输出:
UNIVERSITY JIAOTONG XIAN
#include<iostream>
#include<string>
using namespace std;
int main()
{
string arr[100];
int i = 0;
while (cin >> arr[i])
{
i++;
if (getchar() == 'n')
break;
}
i--;
for (int j = i; j >= 0; j--)
if (j == i)
cout << arr[j];
else
cout << " " << arr[j];
return 0;
}
2.编程题 - 将字符型数字变为真实的数字
考虑char 数组表示的正整数数字,比如”123”、”976”,现在要将他们变为int型数字,然后将两个数字作加法。
【分析】
一位的字符型数字减去字符’0‘即为该整数,如 ’1‘-’0‘ = 1、’7‘-’0‘ = 7。
如
输入
123
123
输出
246
样例输入:
123 123
样例输出:
246
#define _CRT_SECURE_NO_WARNINGS
#include<iostream>
#include<string>
using namespace std;
int main()
{
char str1[100];
char str2[200];
int s1 = 0;
int s2 = 0;
scanf("%s %s", str1, str2);
for (int i = 0; i < strlen(str1); i++)
s1 = s1 * 10 + (int)(str1[i] - '0');
for (int i = 0; i < strlen(str2); i++)
s2 = s2 * 10 + (int)(str2[i] - '0');
s1 = s1 + s2;
printf("%d", s1);
return 0;
}
3.编程题 - 在一个字符串中寻找某个子串
本题目考虑字符数组形式的串。
【分析】
不断的从母串 str 中取出和子串长度相等的临时子串 temp,与子串 str2 进行比较。如果没有找到子串,返回 -1;成功找到子串,返回子串首字母在母串中的位置,该位置从 0 开始。
样例输入:
abcdef abcba
样例输出:
-1
#define _CRT_SECURE_NO_WARNINGS
#include<stdio.h>
#include<string.h>
int main()
{
char s1[200];
char s2[200];
int num=0;
int k=0;
int len1 = strlen(s1);
int len2 = strlen(s2);
gets_s(s1);
gets_s(s2);
for (int i = 0; i < strlen(s1); i++)
{
num = i;
for (int j = 0; j < strlen(s2); j++)
{
if (s1[i+j] != '