概述
问题 G: 比较字符串
[命题人 : 外部导入]
时间限制 : 1.000 sec 内存限制 : 32 MB
解决: 683提交: 1163统计
题目描述
输入两个字符串,比较两字符串的长度大小关系。
输入
输入第一行表示测试用例的个数m,接下来m行每行两个字符串A和B,字符串长度不超过50。
输出
输出m行。若两字符串长度相等则输出A is equal long to B;若A比B长,则输出A is longer than B;否则输出A is shorter than B。
样例输入 Copy
2 abc xy bbb ccc
样例输出 Copy
abc is longer than xy bbb is equal long to ccc
提交
代码:
#include<cstdio>
#include<cstring>
const int maxn=210;
int main(){
char str1[maxn],str2[maxn];
int n;
scanf("%d",&n);
while(n--){
scanf("%s%s",str1,str2);
int len1=strlen(str1);
int len2=strlen(str2);
if(len1==len2){
printf("%s is equal long to %s",str1,str2);
}else if(len1>len2){
printf("%s is longer than %s",str1,str2);
}else{
printf("%s is shorter than %s",str1,str2);
}
printf("n");
}
return 0;
}
最后
以上就是生动皮卡丘为你收集整理的问题 G: 比较字符串的全部内容,希望文章能够帮你解决问题 G: 比较字符串所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
发表评论 取消回复