我是靠谱客的博主 默默小土豆,最近开发中收集的这篇文章主要介绍ZJU-PAT 1065. A+B and C (64bit) (20),觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Given three integers A, B and C in [-263, 263], you are supposed to tell whether A+B > C.

Input Specification:

The first line of the input gives the positive number of test cases, T (<=10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line "Case #X: true" if A+B>C, or "Case #X: false" otherwise, where X is the case number (starting from 1).

Sample Input:
3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0
Sample Output:
Case #1: false
Case #2: true
Case #3: false

分析:

1.考虑相加溢出的情况

(1)  a > 0 && b>0 && a+b <0  , 因 a+b > c,故true

(2)  a < 0 && b<0 && a+b >0 , 因 a+b < c,故false

2. PAT上不支持 __int64数据,采用long long型数据

#pragma warning (disable:4786)
#include<iostream>
#include<string>
#include<cstdio>
#include<algorithm>
#include<map>
using namespace std;
int main()
{
int T;
cin>>T;
for(int i=1;i<=T;i++)
{
long long int
a,b,c;
cin>>a>>b>>c;
cout<<"Case #"<<i+1<<": ";
bool flag;
long long ans =a+b;
if(a>0 && b>0 && ans<=0)
flag=true;
else if(a<0 && b <0 && ans >= 0)
flag=false;
else
flag = (ans > c);
if(flag)
cout<<"true"<<endl;
else
cout<<"false"<<endl;
}
return 0;
}



最后

以上就是默默小土豆为你收集整理的ZJU-PAT 1065. A+B and C (64bit) (20)的全部内容,希望文章能够帮你解决ZJU-PAT 1065. A+B and C (64bit) (20)所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(80)

评论列表共有 0 条评论

立即
投稿
返回
顶部