我是靠谱客的博主 深情小虾米,最近开发中收集的这篇文章主要介绍动态规划第四题 poj1050 最大子矩阵和,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle. 
As an example, the maximal sub-rectangle of the array: 

0 -2 -7 0 
9 2 -6 2 
-4 1 -4 1 
-1 8 0 -2 
is in the lower left corner: 

9 2 
-4 1 
-1 8 
and has a sum of 15. 

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2

Sample Output

15

本来是求最大子矩阵和,然后 举个例子

1 0 1 0

1 0 1 0

0 1 0 1

本来是求 0 1 

                0 1 的和然后把 第二行加到第一行 就变成了 02

这样矩阵就转化成了求最大连续子序列和 

枚举i j 把 从i行到j 行的每一列的元素加起来 求最大连续子序列和 

#include <iostream>
#include <stdio.h>
#include <cstring>
#define maxn 100+5
#define INF 0x3f3f3f3f
using namespace std;
int a[maxn][maxn];
int main()
{
int n;
while(scanf("%d",&n)!=EOF){
int ans=-INF;
for(int i=0;i<n;i++)
for(int j=0;j<n;j++)
scanf("%d",&a[i][j]);
for(int i=0;i<n;i++){
for(int j=i;j<n;j++){
int sum=0;
for(int k=0;k<n;k++){
for(int m=i;m<=j;m++)
sum+=a[m][k];
if(sum<0)sum=0;
else ans=max(ans,sum);
}
}
}
printf("%dn",ans);
}
return 0;
}

 

最后

以上就是深情小虾米为你收集整理的动态规划第四题 poj1050 最大子矩阵和的全部内容,希望文章能够帮你解决动态规划第四题 poj1050 最大子矩阵和所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(74)

评论列表共有 0 条评论

立即
投稿
返回
顶部