我是靠谱客的博主 丰富月光,最近开发中收集的这篇文章主要介绍HDOJ 题目1867A + B for you again(KMP) A + B for you again,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

A + B for you again

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4407    Accepted Submission(s): 1132


Problem Description
Generally speaking, there are a lot of problems about strings processing. Now you encounter another such problem. If you get two strings, such as “asdf” and “sdfg”, the result of the addition between them is “asdfg”, for “sdf” is the tail substring of “asdf” and the head substring of the “sdfg” . However, the result comes as “asdfghjk”, when you have to add “asdf” and “ghjk” and guarantee the shortest string first, then the minimum lexicographic second, the same rules for other additions.
 

Input
For each case, there are two strings (the chars selected just form ‘a’ to ‘z’) for you, and each length of theirs won’t exceed 10^5 and won’t be empty.
 

Output
Print the ultimate string by the book.
 

Sample Input
  
  
asdf sdfg asdf ghjk
 

Sample Output
  
  
asdfg asdfghjk
 

Author
Wang Ye
 

Source
2008杭电集训队选拔赛——热身赛
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   1866  1277  1358  1869  1868 
有重复的就覆盖掉 然后输出。不过这个得比较字符串str1 str2还得再比较str2 str1 
ac代码
#include<stdio.h>
#include<string.h>
int next[100010];
void getnext(char *s)
{
	int len,j=0,k=-1;
	len=strlen(s);
	next[0]=-1;
	while(j<len)
	{
		if(k==-1||s[k]==s[j])
		{
			j++;
			k++;
			next[j]=k;
			/*if(s[j]!=s[k])
				next[j]=k;
			else
				next[j]=next[k];*/
		}
		else
			k=next[k];
	}
}
int kmp(char *s1,char *s2)
{
	int i=0,j=0,k;
	int len1=strlen(s1),len2=strlen(s2);
	getnext(s2);
	while(i<len1&&j<len2)
	{
		if(j==-1||s1[i]==s2[j])
		{
			i++;
			j++;
		}
		else
			j=next[j];
	}
	if(i==len1)
		return j;
	return 0;
}
int main()
{
	char s1[100010],s2[100010];
	while(scanf("%s%s",s1,s2)!=EOF)
	{
		int x=kmp(s1,s2);
		int y=kmp(s2,s1);
		if(x==y)
		{
			if(strcmp(s1,s2)>0)
			{
				printf("%s",s2);
				printf("%sn",s1+y);
			}
			else
			{
				printf("%s",s1);
				printf("%sn",s2+x);
			}
		}
		else
			if(x>y)
			{
				printf("%s",s1);
				printf("%sn",s2+x);
			}
			else
			{
				printf("%s",s2);
				printf("%sn",s1+y);
			}
	}
}


最后

以上就是丰富月光为你收集整理的HDOJ 题目1867A + B for you again(KMP) A + B for you again的全部内容,希望文章能够帮你解决HDOJ 题目1867A + B for you again(KMP) A + B for you again所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(77)

评论列表共有 0 条评论

立即
投稿
返回
顶部