概述
Rikka with Subset
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)Total Submission(s): 997 Accepted Submission(s): 493
Problem Description
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:
Yuta has n positive A1−An and their sum is m . Then for each subset S of A , Yuta calculates the sum of S .
Now, Yuta has got 2n numbers between [0,m] . For each i∈[0,m] , he counts the number of i s he got as Bi .
Yuta shows Rikka the array Bi and he wants Rikka to restore A1−An .
It is too difficult for Rikka. Can you help her?
Yuta has n positive A1−An and their sum is m . Then for each subset S of A , Yuta calculates the sum of S .
Now, Yuta has got 2n numbers between [0,m] . For each i∈[0,m] , he counts the number of i s he got as Bi .
Yuta shows Rikka the array Bi and he wants Rikka to restore A1−An .
It is too difficult for Rikka. Can you help her?
Input
The first line contains a number
t(1≤t≤70)
, the number of the testcases.
For each testcase, the first line contains two numbers n,m(1≤n≤50,1≤m≤104) .
The second line contains m+1 numbers B0−Bm(0≤Bi≤2n) .
For each testcase, the first line contains two numbers n,m(1≤n≤50,1≤m≤104) .
The second line contains m+1 numbers B0−Bm(0≤Bi≤2n) .
Output
For each testcase, print a single line with
n
numbers
A1−An
.
It is guaranteed that there exists at least one solution. And if there are different solutions, print the lexicographic minimum one.
It is guaranteed that there exists at least one solution. And if there are different solutions, print the lexicographic minimum one.
Sample Input
2 2 3 1 1 1 1 3 3 1 3 3 1
Sample Output
1 2 1 1 1HintIn the first sample, $A$ is $[1,2]$. $A$ has four subsets $[],[1],[2],[1,2]$ and the sums of each subset are $0,1,2,3$. So $B=[1,1,1,1]$
题解:
如果 Bi 是 B 数组中除了 B0 以外第一个值不为 0 的位置,那么显然 i 就是 A 中的最小数。
现在需要求出删掉 i 后的 B 数组,过程大概是反向的背包,即从小到大让 Bj−=Bj−i。
时间复杂度 O(nm)。
我写了两个代码,思想本质上是一样的
#include<cstdio>
#include<string>
#include<cstring>
#include<cstdlib>
#include<cmath>
#include<iostream>
#include<algorithm>
#include<vector>
#include<queue>
#include<map>
#include<set>
#include<stack>
#define ll long long
#define read(a) scanf("%d",&a);
using namespace std;
const int maxn=10005;
ll a[maxn],b[maxn];
int main(){
freopen("test.txt","r",stdin);
int t;
int n,m;
scanf("%d",&t);
while(t--){
scanf("%d %d",&n,&m);
for(int i=0;i<=m;i++){
scanf("%lld",&b[i]);
}
int cnt=0;
int i=1;
while(i<=m){
while(b[i]>0){
a[++cnt]=i;
b[i]--;
for(int j=i+1;j<=m;j++){
if(b[j]>0)
b[j]-=b[j-i];
}
}
i++;
}
for(i=1;i<=cnt;i++){
if(i>1)
printf(" ");
printf("%lld",a[i]);
}
printf("n");
}
return 0;
}
#include<cstdio>
#include<string>
#include<cstring>
#include<cstdlib>
#include<cmath>
#include<iostream>
#include<algorithm>
#include<vector>
#include<queue>
#include<map>
#include<set>
#include<stack>
#define ll long long
//#define read(a) scanf("%d",&a);
using namespace std;
const int maxn=10005;
ll a[maxn],b[maxn];
ll dp[maxn];
int main(){
freopen("test.txt","r",stdin);
int t;
int n,m;
scanf("%d",&t);
while(t--){
memset(dp,0,sizeof(dp));
scanf("%d %d",&n,&m);
for(int i=0;i<=m;i++){
scanf("%lld",&b[i]);
}
int cnt=0;
dp[0]=1;
for(int i=1;i<= m;i++){
b[i]-=dp[i];
for(int j=1;j<=b[i];j++){
a[++cnt]=i;
for(int k=m;k>=i;k--){
dp[k]+=dp[k-i];
}
}
//i++;
}
for(int i=1;i<=cnt;i++){
if(i>1)
printf(" ");
printf("%lld",a[i]);
}
printf("n");
}
return 0;
}
最后
以上就是风趣秀发为你收集整理的hdu6092 Rikka with Subset Rikka with Subset的全部内容,希望文章能够帮你解决hdu6092 Rikka with Subset Rikka with Subset所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
发表评论 取消回复