我是靠谱客的博主 明理狗,最近开发中收集的这篇文章主要介绍Hdu-5869 Different GCD Subarray Query(区间不同值离线算法),觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Problem Description
This is a simple problem. The teacher gives Bob a list of problems about GCD (Greatest Common Divisor). After studying some of them, Bob thinks that GCD is so interesting. One day, he comes up with a new problem about GCD. Easy as it looks, Bob cannot figure it out himself. Now he turns to you for help, and here is the problem:
  
  Given an array a of N positive integers a1,a2,aN1,aN ; a subarray of a is defined as a continuous interval between a1 and aN . In other words, ai,ai+1,,aj1,aj is a subarray of a , for 1ijN . For a query in the form (L,R) , tell the number of different GCDs contributed by all subarrays of the interval [L,R] .
  
 

Input
There are several tests, process till the end of input.
  
  For each test, the first line consists of two integers N and Q , denoting the length of the array and the number of queries, respectively. N positive integers are listed in the second line, followed by Q lines each containing two integers L,R for a query.

You can assume that
  
     1N,Q100000
    
   1ai1000000
 

Output
For each query, output the answer in one line.
 

Sample Input
  
  
5 3 1 3 4 6 9 3 5 2 5 1 5
 

Sample Output
  
  
6 6 6
 

Source
2016 ACM/ICPC Asia Regional Dalian Online
 



题意:给n个数,m个询问,每次问[l,r]区间内的所有子区间的GCD的不同值有多少个。


分析:区间不同值有一种离线的做法,考虑到以每个数为右端点的所有区间最多有log(n)个不同值,我们可以预处理出以每个数为右端点的不同gcd值,然后按照从左到右的顺序处理每个询问,当区间的右端固定时,我们用树状数组记下每种答案左端最晚出现的位置,这样对于每个询问直接用r结尾的总方案数减去(l-1)结尾的总方案数来得到答案。


#include<iostream>
#include<string>
#include<algorithm>
#include<cstdlib>
#include<cstdio>
#include<set>
#include<map>
#include<vector>
#include<cstring>
#include<stack>
#include<cmath>
#include<queue>
#define INF 0x3f3f3f3f
#define N 100005
using namespace std; 
typedef pair<int,int> pii;
typedef long long ll;
int n,q,ans[N],f[N],a[N],last[N*10];
vector<int> G[N];
int _gcd(int a,int b)
{
   if(b == 0) return a;
   a %= b;
   return _gcd(b,a);
}
int lowbit(int x)
{
	return x & (-x);
}
void Insert(int k,int x)
{
	while(k <= n)
	{
		f[k] += x;
		k += lowbit(k);
	}
}
int Find(int k)
{
	int ans = 0;
	while(k)
	{
		ans += f[k];
		k -= lowbit(k);
	}
	return ans;
}
struct thing
{
	int l,r;	
}ask[N];
int main()
{
	while(~scanf("%d%d",&n,&q))
	{
		memset(last,0,sizeof(last));
		memset(f,0,sizeof(f));
		for(int i = 1;i <= n;i++) 
		{
			scanf("%d",&a[i]);
			G[i].clear();
		}
		for(int i = 1;i <= q;i++) 
		{
			scanf("%d%d",&ask[i].l,&ask[i].r);
			G[ask[i].r].push_back(i);
		}
		vector<pii> pre;
		for(int i = 1;i <= n;i++)
		{
			vector<pii> tmp;
			pre.push_back(make_pair(a[i],i));
			for(pii v : pre)
			{
				if(tmp.size() && _gcd(v.first,a[i]) == tmp[tmp.size()-1].first) tmp[tmp.size()-1] = make_pair(_gcd(v.first,a[i]),v.second);
				else tmp.push_back(make_pair(_gcd(v.first,a[i]),v.second));
			}
			for(pii v : tmp)
			{
				if(!last[v.first] || last[v.first] < v.second)
				{
					if(last[v.first]) Insert(last[v.first],-1);
					last[v.first] = v.second;
					Insert(last[v.first],1);
				}
			}
			pre = tmp;
			for(int v : G[i]) ans[v] = Find(ask[v].r) - Find(ask[v].l-1);
		}
		for(int i = 1;i <= q;i++) printf("%dn",ans[i]);
	}
}


最后

以上就是明理狗为你收集整理的Hdu-5869 Different GCD Subarray Query(区间不同值离线算法)的全部内容,希望文章能够帮你解决Hdu-5869 Different GCD Subarray Query(区间不同值离线算法)所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(61)

评论列表共有 0 条评论

立即
投稿
返回
顶部