概述
原题目:
Sometimes some mathematical results are hard to believe. One of the common problems is the birthday paradox. Suppose you are in a party where there are 23 people including you. What is the probability that at least two people in the party have same birthday? Surprisingly the result is more than 0.5. Now here you have to do the opposite. You have given the number of days in a year. Remember that you can be in a different planet, for example, in Mars, a year is 669 days long. You have to find the minimum number of people you have to invite in a party such that the probability of at least two people in the party have same birthday is at least 0.5.
Input
Input starts with an integer T (≤ 20000), denoting the number of test cases.
Each case contains an integer n (1 ≤ n ≤ 105) in a single line, denoting the number of days in a year in the planet.
Output
For each case, print the case number and the desired result.
Sample Input
2
365
669
Sample Output
Case 1: 22
Case 2: 30
中文概要:计算至少多少人能使至少其中两人生日相同概率大于50%
#include<cstdio>
#include<cmath>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#include<iostream>
#include<queue>
using namespace std;
int main()
{
int N,n,c=1,a;
double p,t;
scanf("%d",&N);
while(N--)
{
p=1.0;
t=0;
scanf("%d",&n);
a=0;
while(t<0.5)//大于0.5既符合题目要求,不再计算
{
a++;
p*=(n-a)*1.0/n;//计算
t=1-p;
}
printf("Case %d: %dn",c++,a);
}
return 0;
}
思路:
生日悖论(Birthday paradox)是指,如果一个房间里有23个或23个以上的人,那么至少有两个人的生日相同的概率要大于50%。这就意味着在一个典型的标准小学班级(30人)中,存在两人生日相同的可能性更高。对于60或者更多的人,这种概率要大于99%。从引起逻辑矛盾的角度来说生日悖论并不是一种悖论,从这个数学事实与一般直觉相抵触的意义上,它才称得上是一个悖论。大多数人会认为,23人中有2人生日相同的概率应该远远小于50%。
生日悖论的简介与计算原理: 生日悖论
计算对立事件即可:
1 - (n-1)/ n - ( n - 2 ) / n ….(n-k)/n
最后
以上就是含糊咖啡豆为你收集整理的Birthday Paradox (概率论)的全部内容,希望文章能够帮你解决Birthday Paradox (概率论)所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
发表评论 取消回复