我是靠谱客的博主 不安音响,最近开发中收集的这篇文章主要介绍UVA - 10004 - Bicoloring (简单图论-着色判断)   Bicoloring  ,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

UVA - 10004

Bicoloring
Time Limit: 3000MS Memory Limit: Unknown 64bit IO Format: %lld & %llu

Submit Status

Description


  Bicoloring 

In 1976 the ``Four Color Map Theorem" was proven with the assistance of a computer. This theorem states that every map can be colored using only four colors, in such a way that no region is colored using the same color as a neighbor region.

Here you are asked to solve a simpler similar problem. You have to decide whether a given arbitrary connected graph can be bicolored. That is, if one can assign colors (from a palette of two) to the nodes in such a way that no two adjacent nodes have the same color. To simplify the problem you can assume:

  • no node will have an edge to itself.
  • the graph is nondirected. That is, if a node a is said to be connected to a node b, then you must assume that b is connected to a.
  • the graph will be strongly connected. That is, there will be at least one path from any node to any other node.

Input 

The input consists of several test cases. Each test case starts with a line containing the number  n ( 1 <  n < 200) of different nodes. The second line contains the number of edges  l. After this,  l lines will follow, each containing two numbers that specify an edge between the two nodes that they represent. A node in the graph will be labeled using a number  a (  $0 le a < n$).

An input with n = 0 will mark the end of the input and is not to be processed.

Output 

You have to decide whether the input graph can be bicolored or not, and print it as shown below.

Sample Input 

3
3
0 1
1 2
2 0
9
8
0 1
0 2
0 3
0 4
0 5
0 6
0 7
0 8
0

Sample Output 

NOT BICOLORABLE.
BICOLORABLE.



Miguel Revilla 
2000-08-21

Source

Root :: Competitive Programming 3: The New Lower Bound of Programming Contests (Steven & Felix Halim) :: Graph :: Graph Traversal ::  Bipartite Graph Check
Root :: Competitive Programming 2: This increases the lower bound of Programming Contests. Again (Steven & Felix Halim) :: Graph :: Graph Traversal ::  Bipartite Graph Check
Root :: AOAPC I: Beginning Algorithm Contests (Rujia Liu) :: Volume 2. Data Structures ::  Graphs
Root :: Programming Challenges (Skiena & Revilla) ::  Chapter 9
Root :: Competitive Programming: Increasing the Lower Bound of Programming Contests (Steven & Felix Halim) :: Chapter 4. Graph :: Breadth First Search ::  Variants

Submit Status







思路:DFS,每次使一个点着色(这里抽象颜色为1或2),每次要着色这个点之前加个判断,看是否现在满不满足与之相邻的点是否是同一种颜色


AC代码:

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <cmath>
#define LL long long
#define INF 0x7fffffff
using namespace std;
const int maxn = 205;
int color[maxn];
int map[maxn][maxn];
int n, l;
int judge(int x) {
int f1 = 0, f2 = 0;
for(int i = 0; i < n; i++) {
if(map[x][i]) {
if(color[i] == 1) f1 = 1;
else if(color[i] == 2) f2 = 1;
}
}
if(f1 && f2) return 1;
return 0;
}
int dfs(int x) {
for(int i = 0; i < n; i++) {
if(map[x][i] && !color[i]) {
if(judge(i)) return 0;
if(color[x] == 1) color[i] = 2;
else if(color[x] == 2) color[i] = 1;
dfs(i);
}
}
return 1;
}
int main() {
while(scanf("%d", &n), n) {
scanf("%d", &l);
memset(map, 0, sizeof(map));
for(int i = 0; i < l; i++) {
int u, v;
scanf("%d %d", &u, &v);
map[u][v] = 1;
map[v][u] = 1;
}
/*for(int i = 0; i< n; i++, printf("n")) {
for(int j = 0; j < n; j++) {
printf("%d ", map[i][j]);
}
}*/
memset(color, 0, sizeof(color));
color[0] = 1;
if(dfs(0)) {
//for(int i = 0; i < n; i++) printf("%d ", color[i]);
printf("BICOLORABLE.n");
}
else {
//for(int i = 0; i < n; i++) printf("%d ", color[i]);
printf("NOT BICOLORABLE.n");
}
}
return 0;
} 















最后

以上就是不安音响为你收集整理的UVA - 10004 - Bicoloring (简单图论-着色判断)   Bicoloring  的全部内容,希望文章能够帮你解决UVA - 10004 - Bicoloring (简单图论-着色判断)   Bicoloring  所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(58)

评论列表共有 0 条评论

立即
投稿
返回
顶部