概述
算法训练 9-7链表数据求和操作
时间限制:1.0s 内存限制:512.0MB
读入10个复数,建立对应链表,然后求所有复数的和。
样例输入
1 2
1 3
4 5
2 3
3 1
2 1
4 2
2 2
3 3
1 1
样例输出
23+23i
求和而已,直接进行计算:
#include <stdio.h>
int main()
{
int a,b;
int suma=0,sumb=0;
int i;
for(i=1;i<=10;i++)
{
scanf("%d %d",&a,&b);
suma+=a;
sumb+=b;
}
printf("%d",suma);
if(sumb>=0)
printf("+%di",sumb);
return 0;
}
但这道题目当然是要用链表做的。
#include <stdio.h>
#include<malloc.h>
typedef struct linknode
{
int x;
int y;
struct linknode *next;
}node;
int main()
{
node *begin=(node*)malloc(sizeof(node));
node *q=begin,*p;
int m=0,n=0;
scanf("%d %d",&q->x,&q->y);
int i;
for(i=1;i<10;i++)
{
p=(node*)malloc(sizeof(node));
scanf("%d%d",&p->x,&p->y);
q->next=p;
q=p;
}
p->next=NULL;
while(begin!=NULL)
{
m+=begin->x;
n+=begin->y;
begin=begin->next;
}
printf("%d+%di",m,n);
return 0;
}
最后
以上就是深情冬瓜为你收集整理的算法训练 9-7链表数据求和操作的全部内容,希望文章能够帮你解决算法训练 9-7链表数据求和操作所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
发表评论 取消回复