我是靠谱客的博主 无情西装,最近开发中收集的这篇文章主要介绍1028 List Sorting (25 分),觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

1028 List Sorting (25 分)

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input Specification:

Each input file contains one test case. For each case, the first line contains two integers N (≤10​5​​) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student’s record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output Specification:

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID’s; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID’s in increasing order.

Sample Input 1:

3 1
000007 James 85
000010 Amy 90
000001 Zoe 60
Sample Output 1:

000001 Zoe 60
000007 James 85
000010 Amy 90
Sample Input 2:

4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98
Sample Output 2:

000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60
Sample Input 3:

4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90
Sample Output 3:

000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90

note:

  • 是不是一开始写的时候最后一个测试点运行超时呢?没想到居然是输入输出流的选择问题,注意!:scanf和printf比cin和cout要快多了,所以大家平常尽量少用cin和cout来输出,尤其是这样卡时间的竞赛或考试题~
  • string类型转换为用%s输出,可用c_str()函数
  • 所以吃一堑,长一智,此题题意在PAT题目中算是最简单明了的,就一定要谨防在其他方面设坑~这点在平常练习的时候就要注意和总结技巧
#include <iostream>
#include <bits/stdc++.h>
using namespace std;

struct node
{
    string id,name;
    int grade;
    node(){}
    node(string id,string name,int grade):id(id),name(name),grade(grade){}
};

int n,c;

bool cmp(const node&a ,const node &b)
{
    if(c==1) return a.id < b.id;
    if(c==2){
        if(a.name!=b.name) return a.name < b.name;
        else return a.id < b.id;
    }
    if(c==3){
        if(a.grade!=b.grade) return a.grade < b.grade;
        else return a.id < b.id;
    }
}

int main()
{
  scanf("%d%d",&n,&c);
  vector<node> v(n);
  for(int i = 0; i < n; i++){
    cin >>v[i].id>>v[i].name>>v[i].grade;
  }
  sort(v.begin(),v.end(),cmp);
  for(int i = 0; i < n; i++){
    printf("%s %s %dn",v[i].id.c_str(),v[i].name.c_str(),v[i].grade);
  }

}

最后

以上就是无情西装为你收集整理的1028 List Sorting (25 分)的全部内容,希望文章能够帮你解决1028 List Sorting (25 分)所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(48)

评论列表共有 0 条评论

立即
投稿
返回
顶部