我是靠谱客的博主 饱满外套,最近开发中收集的这篇文章主要介绍CodeForces 1 A.Theatre Square(水~),觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Description

aa 的砖铺满一个 nm 的地面问最少需要几块

Input

三个整数 n,m,a(1n,m,a109)

Output

输出最少需要几块砖

Sample Input

6 6 4

Sample Output

4

Solution

水题, ans=nama

Code

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
#include<queue>
#include<map>
#include<set>
#include<ctime>
using namespace std;
typedef long long ll;
typedef pair<int,int>P;
const int INF=0x3f3f3f3f,maxn=100001;
int n,m,a;
int main()
{
while(~scanf("%d%d%d",&n,&m,&a))
{
int x=(n+a-1)/a,y=(m+a-1)/a;
printf("%I64dn",(ll)x*y);
}
return 0;
}

最后

以上就是饱满外套为你收集整理的CodeForces 1 A.Theatre Square(水~)的全部内容,希望文章能够帮你解决CodeForces 1 A.Theatre Square(水~)所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(40)

评论列表共有 0 条评论

立即
投稿
返回
顶部