我是靠谱客的博主 酷炫翅膀,最近开发中收集的这篇文章主要介绍AOJ (C++ Programming II)—4-B-rotate4-B-rotate,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

4-B-rotate

题目

Write a program which reads a sequence of integers A={a0,a1,…,an−1} and rotate specified elements by a list of the following operation: rotate(b,m,e): For each integer k (0≤k<(e−b)), move element b+k to the place of element b+((k+(e−m))mod(e−b)).
输入
The input is given in the following format.
n
a0 a1…,an−1
q
b1 m1 e1
b2 m2 e2
:
bq mq eq
In the first line, n (the number of elements in A) is given. In the second line, ai (each element in A) are given. In the third line, the number of queries q is given and each query is given by three integers bimiei in the following q lines.
输出
Print all elements of A in a line after performing the given operations. Put a single space character between adjacency elements and a newline at the end of the last element.
样例输入
11
1 2 3 4 5 6 7 8 9 10 11
1
2 6 9
样例输出
1 2 7 8 9 3 4 5 6 10 11

题解(代码流程)

#include<bits/stdc++.h>
#include<iostream>
using namespace std;
int main() {
ios::sync_with_stdio(false);
cin.tie(nullptr);
cout.tie(nullptr);
int n, q;
cin >> n;
vector<int> A(n);//嵌套数组
for (int i = 0; i < n; i++)cin >> A[i];
cin >> q;
while (q--) {
int b, m, e;
cin >> b >> m >> e;
rotate(A.begin() + b, A.begin() + m, A.begin() + e);//直接使用rotate代入四个参数
}
for (auto e:A) {
cout << e << " ";
}
cout << endl;
return 0;
}

小结

学会运用rotate函数来旋转范围中的元素顺序

rotate()
rotate() 的第一个参数是这个序列的开始迭代器;第二个参数是指向新的第一个元素的迭代器,它必定在序列之内。第三个参数是这个序列的结束迭代器。。

最后

以上就是酷炫翅膀为你收集整理的AOJ (C++ Programming II)—4-B-rotate4-B-rotate的全部内容,希望文章能够帮你解决AOJ (C++ Programming II)—4-B-rotate4-B-rotate所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(33)

评论列表共有 0 条评论

立即
投稿
返回
顶部