我是靠谱客的博主 糟糕蜗牛,这篇文章主要介绍java数学表达式_Java计算数学表达式(字符串形式),现在分享给大家,希望可以做个参考。

我的个人博客:zhang0peter的个人博客

题目: 表达式计算II Write a program that reads an expression in a line as input and prints out the result. Only integers and operators below are allowed in the expression: ( )+ - * / % 输入格式: A line of expression. 输出格式: The result. 输入样例: (2+32)/2-6 输出样例: 11

import java.util.Scanner;

import java.util.Stack;

public class Hello {

public static void main(String[] args) {

Scanner scanner = new Scanner(System.in);

String str = scanner.nextLine();

//double result1 = compute("-3*-3");

double result1 = compute(str);

System.out.println((int) result1);

}

public static int priority(char s) {

switch (s) {

case '(':

case ')':

return 0;

case '-':

case '+':

return 1;

最后

以上就是糟糕蜗牛最近收集整理的关于java数学表达式_Java计算数学表达式(字符串形式)的全部内容,更多相关java数学表达式_Java计算数学表达式(字符串形式)内容请搜索靠谱客的其他文章。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(61)

评论列表共有 0 条评论

立即
投稿
返回
顶部