我的个人博客:zhang0peter的个人博客
题目: 表达式计算II Write a program that reads an expression in a line as input and prints out the result. Only integers and operators below are allowed in the expression: ( )+ - * / % 输入格式: A line of expression. 输出格式: The result. 输入样例: (2+32)/2-6 输出样例: 11
import java.util.Scanner;
import java.util.Stack;
public class Hello {
public static void main(String[] args) {
Scanner scanner = new Scanner(System.in);
String str = scanner.nextLine();
//double result1 = compute("-3*-3");
double result1 = compute(str);
System.out.println((int) result1);
}
public static int priority(char s) {
switch (s) {
case '(':
case ')':
return 0;
case '-':
case '+':
return 1;
最后
以上就是糟糕蜗牛最近收集整理的关于java数学表达式_Java计算数学表达式(字符串形式)的全部内容,更多相关java数学表达式_Java计算数学表达式(字符串形式)内容请搜索靠谱客的其他文章。
发表评论 取消回复