概述
题目描述
求串的最长重复子串长度(子串不重叠)。例如:abcaefabcabc的最长重复子串是串abca,长度为4。
输入
测试次数t
t个测试串
输出
对每个测试串,输出最长重复子串长度,若没有重复子串,输出-1.
样例输入
3
abcaefabcabc
szu0123szu
szuabcefg
样例输出
4
3
-1
思路:
实现代码:
#include<iostream>
#include<string>
using namespace std;
void GetNext(string p, int next[])
{
next[0] = -1;
int i, j;
i = 0;
j = -1;
while (i<p.length())
{
if (j == -1 || p[i] == p[j])
{
++i;
++j;
next[i] = j;
}
else
j = next[j];
}
}
int main()
{
int n;
cin >> n;
string s;
string re;
int i, j = -1,k;
int max = 0;
while (n--)
{
int next[100] = { 0 };
max = -1;
cin >> s;
re=s;
for (i = 0, k = s.length() - 1; k >= 0; i++, k--)
{
re[i] = s[k];
}
GetNext(s, next);
for (i = 0; i <= s.length(); ++i)
{
if (next[i]>max && next[i]<=s.length()/2)
max = next[i];
}
GetNext(re, next);
for (i = 0; i <= re.length(); ++i)
{
if (next[i]>max && next[i]<=re.length()/2)
max = next[i];
}
if (max == 0)
cout << j << endl;
else
{
cout << max << endl;
}
}
return 0;
}
最后
以上就是高大信封为你收集整理的DS--最长重复子串的全部内容,希望文章能够帮你解决DS--最长重复子串所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
发表评论 取消回复