我是靠谱客的博主 鲜艳星月,最近开发中收集的这篇文章主要介绍hdu 1690 Bus System (有点恶心),觉得挺不错的,现在分享给大家,希望可以做个参考。

概述



Problem Description
Because of the huge population of China, public transportation is very important. Bus is an important transportation method in traditional public transportation system. And it’s still playing an important role even now.
The bus system of City X is quite strange. Unlike other city’s system, the cost of ticket is calculated based on the distance between the two stations. Here is a list which describes the relationship between the distance and the cost.



Your neighbor is a person who is a really miser. He asked you to help him to calculate the minimum cost between the two stations he listed. Can you solve this problem for him?
To simplify this problem, you can assume that all the stations are located on a straight line. We use x-coordinates to describe the stations’ positions.
 

Input
The input consists of several test cases. There is a single number above all, the number of cases. There are no more than 20 cases.
Each case contains eight integers on the first line, which are L1, L2, L3, L4, C1, C2, C3, C4, each number is non-negative and not larger than 1,000,000,000. You can also assume that L1<=L2<=L3<=L4.
Two integers, n and m, are given next, representing the number of the stations and questions. Each of the next n lines contains one integer, representing the x-coordinate of the ith station. Each of the next m lines contains two integers, representing the start point and the destination.
In all of the questions, the start point will be different from the destination.
For each case,2<=N<=100,0<=M<=500, each x-coordinate is between -1,000,000,000 and 1,000,000,000, and no two x-coordinates will have the same value.
 

Output
For each question, if the two stations are attainable, print the minimum cost between them. Otherwise, print “Station X and station Y are not attainable.” Use the format in the sample.
 

Sample Input
2 1 2 3 4 1 3 5 7 4 2 1 2 3 4 1 4 4 1 1 2 3 4 1 3 5 7 4 1 1 2 3 10 1 4
 

Sample Output
Case 1: The minimum cost between station 1 and station 4 is 3. The minimum cost between station 4 and station 1 is 3. Case 2: Station 1 and station 4 are not attainable.

#include<queue>
#include<stack>
#include<vector>
#include<math.h>
#include<stdio.h>
#include<numeric>//STL数值算法头文件
#include<stdlib.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#include<functional>//模板类头文件
using namespace std;
const __int64
INF=1e18+10;
const __int64
maxn=110;
__int64
t,n,m,x,st,ed;
__int64
tu[maxn][maxn];
__int64
dist[5],cost[5],k[maxn];
__int64 distan(__int64
d)
{
if(d>0&&d<=dist[1])
return cost[1];
if(d<=dist[2])
return cost[2];
if(d<=dist[3])
return cost[3];
if(d<=dist[4])
return cost[4];
return INF;
}
__int64 jisuan(__int64 a)
{
return a<0?-a:a;
}
void floyd()
{
__int64 i,j,k;
for(k=1; k<=n; k++)
for(i=1; i<=n; i++)
for(j=1; j<=n; j++)
if(tu[i][j]>tu[i][k]+tu[k][j])
tu[i][j]=tu[i][k]+tu[k][j];
}
int main()
{
__int64 i,j,Case=1;
scanf("%I64d",&t);
while(t--)
{
for(i=1; i<=4; i++)
scanf("%I64d",&dist[i]);
for(i=1; i<=4; i++)
scanf("%I64d",&cost[i]);
scanf("%I64d %I64d",&n,&m);
for(i=1; i<=n; i++) scanf("%I64d",&k[i]);
for(i=0; i<=n; i++)
for(j=0; j<=n; j++)
tu[i][j]=i==j?0:INF;
for(i=1; i<=n; i++)
for(j=i; j<=n; j++)
tu[i][j]=tu[j][i]=distan(jisuan(k[j]-k[i]));
floyd();
printf("Case %d:n",Case++);
while(m--)
{
scanf("%I64d %I64d",&st,&ed);
if(tu[st][ed]==INF)
printf("Station %I64d and station %I64d are not attainable.n",st,ed);
else
printf("The minimum cost between station %I64d and station %I64d is %I64d.n",st,ed,tu[st][ed]);
}
}
return 0;
}













Problem Description
Because of the huge population of China, public transportation is very important. Bus is an important transportation method in traditional public transportation system. And it’s still playing an important role even now.
The bus system of City X is quite strange. Unlike other city’s system, the cost of ticket is calculated based on the distance between the two stations. Here is a list which describes the relationship between the distance and the cost.



Your neighbor is a person who is a really miser. He asked you to help him to calculate the minimum cost between the two stations he listed. Can you solve this problem for him?
To simplify this problem, you can assume that all the stations are located on a straight line. We use x-coordinates to describe the stations’ positions.
 

Input
The input consists of several test cases. There is a single number above all, the number of cases. There are no more than 20 cases.
Each case contains eight integers on the first line, which are L1, L2, L3, L4, C1, C2, C3, C4, each number is non-negative and not larger than 1,000,000,000. You can also assume that L1<=L2<=L3<=L4.
Two integers, n and m, are given next, representing the number of the stations and questions. Each of the next n lines contains one integer, representing the x-coordinate of the ith station. Each of the next m lines contains two integers, representing the start point and the destination.
In all of the questions, the start point will be different from the destination.
For each case,2<=N<=100,0<=M<=500, each x-coordinate is between -1,000,000,000 and 1,000,000,000, and no two x-coordinates will have the same value.
 

Output
For each question, if the two stations are attainable, print the minimum cost between them. Otherwise, print “Station X and station Y are not attainable.” Use the format in the sample.
 

Sample Input
2 1 2 3 4 1 3 5 7 4 2 1 2 3 4 1 4 4 1 1 2 3 4 1 3 5 7 4 1 1 2 3 10 1 4
 

Sample Output
Case 1: The minimum cost between station 1 and station 4 is 3. The minimum cost between station 4 and station 1 is 3. Case 2: Station 1 and station 4 are not attainable.

最后

以上就是鲜艳星月为你收集整理的hdu 1690 Bus System (有点恶心)的全部内容,希望文章能够帮你解决hdu 1690 Bus System (有点恶心)所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(62)

评论列表共有 0 条评论

立即
投稿
返回
顶部