概述
Time limit : 2sec / Memory limit : 1024MB
Score : 600 points
Problem Statement
Takahashi has N balls with positive integers written on them. The integer written on the i-th ball is Ai. He would like to form some number of pairs such that the sum of the integers written on each pair of balls is a power of 2. Note that a ball cannot belong to multiple pairs. Find the maximum possible number of pairs that can be formed.
Here, a positive integer is said to be a power of 2 when it can be written as 2t using some non-negative integer t.
Constraints
- 1≤N≤2×105
- 1≤Ai≤109
- Ai is an integer.
Input
Input is given from Standard Input in the following format:
N
A1 A2 … AN
Output
Print the maximum possible number of pairs such that the sum of the integers written on each pair of balls is a power of 2.
Sample Input 1
Copy
3
1 2 3
Sample Output 1
Copy
1
We can form one pair whose sum of the written numbers is 4 by pairing the first and third balls. Note that we cannot pair the second ball with itself.
Sample Input 2
Copy
5
3 11 14 5 13
Sample Output 2
Copy
2
//nqiiii大佬的代码
//看大佬的代码,似乎考虑最优解的情况,即1-15,1-7,7-9,排序后再贪心,但是我看不懂
#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
int n, ans;
multiset<ll> st;//因为数据可能重复,所以用multiset
int main() {
scanf("%d", &n);
for (int i = 1; i <= n; ++i) {
ll x; scanf("%lld", &x);
st.insert(x);
}
while (!st.empty()) {
ll v = *--st.end();//取st最后一位数据
st.erase(--st.end());//将最后一位数据抹去,避免下面find找到自己
for (int i = 0; i <= 32; ++i) {//2^32是int范围内的极限,循环int内的2的幂
ll t = (1ll << i) - v;
if (st.find(t) != st.end()) {//如果t在st中存在,抹去,ans++,并且break
++ans; st.erase(st.find(t)); break;
}
}
}
printf("%d", ans);
}
最后
以上就是烂漫书包为你收集整理的B - Powers of two的全部内容,希望文章能够帮你解决B - Powers of two所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
发表评论 取消回复