概述
The "Hamilton cycle problem" is to find a simple cycle that contains every vertex in a graph. Such a cycle is called a "Hamiltonian cycle".
In this problem, you are supposed to tell if a given cycle is a Hamiltonian cycle.
Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive integers N (2<N≤200), the number of vertices, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format Vertex1 Vertex2
, where the vertices are numbered from 1 to N. The next line gives a positive integer K which is the number of queries, followed by K lines of queries, each in the format:
n V1 V2 ... Vn
where n is the number of vertices in the list, and Vi's are the vertices on a path.
Output Specification:
For each query, print in a line YES
if the path does form a Hamiltonian cycle, or NO
if not.
Sample Input:
6 10
6 2
3 4
1 5
2 5
3 1
4 1
1 6
6 3
1 2
4 5
6
7 5 1 4 3 6 2 5
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 3 4 5 2 6
7 6 1 2 5 4 3 1
Sample Output:
YES
NO
NO
NO
YES
NO
思路:哈密顿回路:(1)构成环,首尾节点一样(2)覆盖所有点,并且除了第一个节点,其他节点只出现一次
程序:
#include <cstdio>
#include <vector>
#include <set>
using namespace std;
int edge[201][201];
int n,m;
bool isHamilton(vector<int> v)
{
int size = v.size();
set<int> temp;
if(size != n + 1)
return false;
if(v[0] != v[size-1] && size > 1)
return false;
for(int i = 0; i < size - 1; i++)
{
if(!edge[v[i]][v[i+1]])
return false;
if(temp.count(v[i]) != 0)
return false;
temp.insert(v[i]);
}
return true;
}
int main()
{
scanf("%d%d",&n,&m);
for(int i = 0; i < m; i++)
{
int a,b;
scanf("%d%d",&a,&b);
edge[a][b] = edge[b][a] = 1;
}
int k;
scanf("%d",&k);
for(int i = 0; i < k; i++)
{
int nn;
scanf("%d",&nn);
vector<int> v;
for(int i = 0; i < nn; i++)
{
int vex;
scanf("%d",&vex);
v.push_back(vex);
}
if(isHamilton(v))
printf("YESn");
else
printf("NOn");
}
return 0;
}
最后
以上就是幽默机器猫为你收集整理的PAT 1122 Hamiltonian Cycle(25 分)的全部内容,希望文章能够帮你解决PAT 1122 Hamiltonian Cycle(25 分)所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
发表评论 取消回复