我是靠谱客的博主 洁净芒果,最近开发中收集的这篇文章主要介绍HDU1387(队列+hash)Team Queue,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Team Queue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 979    Accepted Submission(s): 331


Problem Description
Queues and Priority Queues are data structures which are known to most computer scientists. The Team Queue, however, is not so well known, though it occurs often in everyday life. At lunch time the queue in front of the Mensa is a team queue, for example.
In a team queue each element belongs to a team. If an element enters the queue, it first searches the queue from head to tail to check if some of its teammates (elements of the same team) are already in the queue. If yes, it enters the queue right behind them. If not, it enters the queue at the tail and becomes the new last element (bad luck). Dequeuing is done like in normal queues: elements are processed from head to tail in the order they appear in the team queue.

Your task is to write a program that simulates such a team queue.

 

Input
The input will contain one or more test cases. Each test case begins with the number of teams t (1<=t<=1000). Then t team descriptions follow, each one consisting of the number of elements belonging to the team and the elements themselves. Elements are integers in the range 0 - 999999. A team may consist of up to 1000 elements.

Finally, a list of commands follows. There are three different kinds of commands:

ENQUEUE x - enter element x into the team queue
DEQUEUE - process the first element and remove it from the queue
STOP - end of test case
The input will be terminated by a value of 0 for t.

 

Output
For each test case, first print a line saying "Scenario #k", where k is the number of the test case. Then, for each DEQUEUE command, print the element which is dequeued on a single line. Print a blank line after each test case, even after the last one.
 

Sample Input
  
  
2 3 101 102 103 3 201 202 203 ENQUEUE 101 ENQUEUE 201 ENQUEUE 102 ENQUEUE 202 ENQUEUE 103 ENQUEUE 203 DEQUEUE DEQUEUE DEQUEUE DEQUEUE DEQUEUE DEQUEUE STOP 2 5 259001 259002 259003 259004 259005 6 260001 260002 260003 260004 260005 260006 ENQUEUE 259001 ENQUEUE 260001 ENQUEUE 259002 ENQUEUE 259003 ENQUEUE 259004 ENQUEUE 259005 DEQUEUE DEQUEUE ENQUEUE 260002 ENQUEUE 260003 DEQUEUE DEQUEUE DEQUEUE DEQUEUE STOP 0
 

Sample Output
  
  
Scenario #1 101 102 103 201 202 203 Scenario #2 259001 259002 259003 259004 259005 260001
 
 

直接用队列+hash,模拟会由于查找插入位置而导致超时,时间复杂度也没有升高,超时原因真心不知道 #include<iostream> #include<vector> using namespace std; #define MAX 999999+10 int data[MAX];

int main() {  char str[20];  int n,i,j,m,temp;  int tag=0;  while(scanf("%d",&n)!=EOF&&n)  {   tag++;   memset(data,0,sizeof(data));   vector<int>team;   vector<int>::iterator iter,index;   for(i=1;i<=n;i++)   {    scanf("%d",&m);    for(j=1;j<=m;j++)    {     scanf("%d",&temp);     data[temp]=i;    }   }      printf("Scenario #%dn",tag);   while(scanf("%s",str)&&strcmp(str,"STOP")!=0)//&&str!="STOP")   {

  if(strcmp(str,"ENQUEUE")==0)   {   scanf("%d",&temp);   index=team.end();   for(iter=team.begin();iter!=team.end();iter++)   {   if(data[(*iter)]==data[temp])   {   index=iter+1;   break;   }   }   team.insert(index,temp);   }   else if(strcmp(str,"DEQUEUE")==0)   {   printf("%dn",(*team.begin()));   team.erase(team.begin());   }   }   printf("n");   team.clear();  }  return 0; }

 

 

用队列模拟,具体根据所属团号作为队列数组下标,插入式时间复杂度为为O(1),是在看了大神的代码后才自己敲出来的

#include<iostream> #include<queue> #include<map> using namespace std;

int main() {  char str[20];  int n,i,j,m,temp;  int tag=0;  bool visited[1010];  while(scanf("%d",&n)!=EOF&&n)  {   tag++;   queue<int>que[1010],tol_que;   map<int,int>data;   memset(visited,0,sizeof(visited));   for(i=1;i<=n;i++)   {    scanf("%d",&m);    for(j=1;j<=m;j++)    {     scanf("%d",&temp);     data[temp]=i;

   }   }      printf("Scenario #%dn",tag);   while(scanf("%s",str)&&strcmp(str,"STOP")!=0)//&&str!="STOP")   {        if(strcmp(str,"ENQUEUE")==0)    {     scanf("%d",&temp);     que[data[temp]].push(temp);     if(visited[data[temp]]==false)     {      tol_que.push(data[temp]);      visited[data[temp]]=true;     }    }    else if(strcmp(str,"DEQUEUE")==0)    {     printf("%dn",que[tol_que.front()].front());     que[tol_que.front()].pop();     if(que[tol_que.front()].empty()==true)     {      visited[tol_que.front()]=false;      tol_que.pop();

    }

   }   }   printf("n");  }  return 0; }

最后

以上就是洁净芒果为你收集整理的HDU1387(队列+hash)Team Queue的全部内容,希望文章能够帮你解决HDU1387(队列+hash)Team Queue所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(45)

评论列表共有 0 条评论

立即
投稿
返回
顶部