我是靠谱客的博主 兴奋大侠,最近开发中收集的这篇文章主要介绍UVa 10115 - Automatic EditingProblem E: Automatic Editing,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Problem E: Automatic Editing

Source file:autoedit.{c, cpp,java, pas}
Input file:autoedit.in
Output file:autoedit.out

Text-processing tools like awk and sed allow you to  automatically perform a sequence of editing operations based on a script. For this problem we consider the specific case in which we want to  perform a series of string replacements, within a single line of text, based on a fixed set of rules.  Each rule specifies the string to find, and the string to replace it with, as shown below.

RuleFindReplace-by
1.ban  bab
2.baba be
3.ana  any
4.ba b hind the g

To perform the edits for a given line of text, start with the first rule.  Replace the first occurrence of the find  string within the text by the replace-by string, then try to  perform the same replacement again on the new text.   Continue until the find string no longer occurs within the text, and then move on to the next rule.   Continue until all the rules have been considered.  Note that (1) when searching for a find string, you always start searching at the beginning of the text, (2) once you have finished using a rule (because the find string no longer occurs) you never use that rule again, and (3) case is significant.

For example, suppose we start with the line

banana boat

and apply these rules.   The sequence of transformations is shown below, where occurrences of a find string are underlined and replacements are boldfaced. Note that rule 1 was used twice, then rule 2 was used once, then rule 3 was used zero times, and then rule 4 was used once.

 Before  After
banana boat      babana boat
babana boat      bababa boat
bababa boat      beba boat
beba boat      behind the goat

The input contains one or more test cases, followed by a line containing only 0 (zero) that signals the end of the file.  Each test case begins with a line containing the number of rules, which will be between 1 and 10.   Each rule is specified by a pair of lines, where the first line is the find string and the second line is the replace-bystring.  Following all the rules is a line containing the text to edit. For each test case, output a line containing the final edited text.

Both find and replace-by strings will be at most 80 characters long.  Find strings will contain at least one  character, but replace-by strings may be empty (indicated in the input file by an empty line).  During the edit process the text may grow as large as 255 characters, but the final output text will be less than 80 characters long.

The first test case in the sample input below corresponds to the example shown above.

Example input:

4
ban
bab
baba
be
ana
any
ba b
hind the g
banana boat
1
t
sh
toe or top
0

Example output:

behind the goat
shoe or shop
   
 
 
#include <stdio.h>
#include <string.h>
int main()
{
    int n,i,k,len,len1,len2;
    char *j,*c,s[300],find[15][100],replace[15][100];
    while(scanf("%d",&n)!=EOF&&n!=0)
    {
        getchar();
        for(int i=0;i<n;i++)
        {
            gets(find[i]);
            gets(replace[i]);
        }
        gets(s);
        for(int i=0;i<n;i++)
        {
            len1=strlen(find[i]);
            len2=strlen(replace[i]);
            while((c=strstr(s,find[i]))&&c!=NULL)
            {
                len=strlen(s);
                if(len1<len2)
                    for(j=&s[len];j>=c+len1;j--)
                        *(j-len1+len2)=*j;
                if(len1>len2)
                    for(j=c+len1;j<=&s[len];j++)
                    *(j+len2-len1)=*j;
                for(j=c,k=0;k<len2;j++,k++)
                    *j=replace[i][k];
            }
        }
        printf("%sn",s);
    }
    return 0;
}

 

最后

以上就是兴奋大侠为你收集整理的UVa 10115 - Automatic EditingProblem E: Automatic Editing的全部内容,希望文章能够帮你解决UVa 10115 - Automatic EditingProblem E: Automatic Editing所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(40)

评论列表共有 0 条评论

立即
投稿
返回
顶部