概述
B - Sports Festival
Time limit : 2sec / Memory limit : 256MB
Score : 700 points
Problem Statement
Takahashi is hosting an sports meet. There are N people who will participate. These people are conveniently numbered 1 through N. Also, there are M options of sports for this event. These sports are numbered 1 through M. Among these options, Takahashi will select one or more sports (possibly all) to be played in the event.
Takahashi knows that Person i's j-th favorite sport is Sport Aij. Each person will only participate in his/her most favorite sport among the ones that are actually played in the event, and will not participate in the other sports.
Takahashi is worried that one of the sports will attract too many people. Therefore, he would like to carefully select sports to be played so that the number of the participants in the sport with the largest number of participants is minimized. Find the minimum possible number of the participants in the sport with the largest number of participants.
Constraints
- 1≤N≤300
- 1≤M≤300
- Ai1 , Ai2 , … , AiM is a permutation of the integers from 1 to M.
Input
Input is given from Standard Input in the following format:
N M A11 A12 … A1M A21 A22 … A2M : AN1 AN2 … ANM
Output
Print the minimum possible number of the participants in the sport with the largest number of participants.
Sample Input 1
4 5 5 1 3 4 2 2 5 3 1 4 2 3 1 4 5 2 5 4 3 1
Sample Output 1
2
Assume that Sports 1, 3 and 4 are selected to be played. In this case, Person 1 will participate in Sport 1, Person 2 in Sport 3, Person 3 in Sport 3 and Person 4 in Sport 4. Here, the sport with the largest number of participants is Sport 3, with two participants. There is no way to reduce the number of participants in the sport with the largest number of participants to 1. Therefore, the answer is 2.
Sample Input 2
3 3 2 1 3 2 1 3 2 1 3
Sample Output 2
3
Since all the people have the same taste in sports, there will be a sport with three participants, no matter what sports are selected. Therefore, the answer is 3.
题意:N个人,M个体育课,每人对每种体育课有喜爱顺序,问开放哪些体育课下,能使最多人选的体育课人数最少(每个人选自己优先喜欢的课)。
思路:最大值最小问题,先考虑二分答案,从每个人最喜欢的课开始遍历,重复执行该操作,筛掉不能选的课。
大意处:check验证时忘记将a[i][0]恢复为1.
# include <bits/stdc++.h>
using namespace std;
int n, m, a[308][308], vis[308], go[308];
bool check(int x)
{
memset(go, 0, sizeof(go));
for(int i=1; i<=n; ++i) a[i][0] = 1;
while(1)
{
memset(vis, 0, sizeof(vis));
bool flag = true;
for(int i=1; i<=n; ++i)
{
while(a[i][0] <= m && go[a[i][a[i][0]]]) ++a[i][0];
if(++vis[a[i][a[i][0]]] > x) {go[a[i][a[i][0]]]=1; flag =false;}
if(a[i][0] > m) return false;
}
if(flag) return true;
}
return false;
}
int main()
{
scanf("%d%d",&n,&m);
for(int i=1; i<=n; ++i)
{
a[i][0] = 1;
for(int j=1; j<=m; ++j)
scanf("%d",&a[i][j]);
}
int l=1, r=n;
while(l<r)
{
int m = l+r>>1;
if(check(m)) r = m;
else l=m+1;
}
printf("%dn",r);
return 0;
}
最后
以上就是害怕灰狼为你收集整理的AGC018:Sports Festival(二分)的全部内容,希望文章能够帮你解决AGC018:Sports Festival(二分)所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
发表评论 取消回复