我是
靠谱客的博主
温柔雪碧,最近开发中收集的这篇文章主要介绍
poj1753(枚举),觉得挺不错的,现在分享给大家,希望可以做个参考。
http://poj.org/problem?id=1753
Flip Game
Time Limit: 1000MS | | Memory Limit: 65536K |
Total Submissions: 19799 | | Accepted: 8566 |
Description
Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules:
- Choose any one of the 16 pieces.
- Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).
Consider the following position as an example:
bwbw
wwww
bbwb
bwwb
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become:
bwbw
bwww
wwwb
wwwb
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal.
Input
The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.
Output
Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).
Sample Input
bwwb
bbwb
bwwb
bwww
Sample Output
4
Source
Northeastern Europe 2000
题意:翻棋子每次翻一个棋子的时候与他相邻的上下左右的棋子的颜色都会变。求最小的次数值得棋盘是清一色,即全是黑或者全是白。
任何一个棋子翻转2次等于没有翻转,翻转1次和>1次的奇数次结果是一样的。为了求最小的翻转次数一个棋子要么不翻要么就翻转一次这题可以用位运算做不过不熟暂时放弃,以后在用吧,说实话这题能弄会就不错了
#include<iostream>
using namespace std;
bool map[6][6], find = false;
int step; //步數
int dr[5] = {-1, 0, 0, 0, 1}; //行的上、左、中、右、下
int dc[5] = {0, -1, 0, 1, 0};//列的
bool isgoal(){ // 判断矩阵是否为同一个颜色。
for(int i = 1; i <= 4; i ++)
for(int j = 1; j <= 4; j ++)
if(map[i][j] != map[1][1])//不成立立即跳出
return false;
return true;
}
void flip(int row, int col){ // 翻动点(row,col)时的map[][]的变化。
for(int i = 0; i < 5; i ++){
int r = row + dr[i], c = col + dc[i];
map[r][c] = !map[r][c];
}
}
void dfs(int row, int col, int dep){ // 点(row,col)为现在是否要操作的点。,step是步数
if(dep == step){
find = isgoal();
return;
}//}//由后面可以发现dfs的走向是从左到右,从上到下的
if(find || row == 5) return;//所以当row==5的时候也已经实现啦
flip(row, col); // 对点(row,col)进行翻动。
if(col < 4) dfs(row, col + 1, dep + 1); //翻,順序搜索当dfs到最右端的时候(即col==4),需要
else dfs(row + 1, 1, dep + 1); //控制dfs的走向转为第二行第一个
flip(row, col); // 還原,等價于不对点(row,col)进行翻动再原地翻转即还原
if(col < 4) dfs(row, col + 1, dep); //不翻,順序搜索 一定要理解,dep不变与dep+1的区别
else dfs(row + 1, 1, dep);
}
int main()
{
char c;
for(int i = 1; i <= 4; i++)
for(int j = 1; j <= 4; j++){
cin >> c;
if(c == 'b') map[i][j] = true;
}
for(step = 0; step <= 16; step ++){ // 枚举 16 步。
dfs(1, 1, 0);
if(find) break;
}
if(find) cout << step << endl;
else cout << "Impossible" << endl;
return 0;
}
发表评论 取消回复