我是靠谱客的博主 热情身影,最近开发中收集的这篇文章主要介绍集训笔记---队列应用(HDUOJ NO.1387 Team Queue )Team Queue,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Team Queue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3687    Accepted Submission(s): 1313


 

Problem Description

Queues and Priority Queues are data structures which are known to most computer scientists. The Team Queue, however, is not so well known, though it occurs often in everyday life. At lunch time the queue in front of the Mensa is a team queue, for example.
In a team queue each element belongs to a team. If an element enters the queue, it first searches the queue from head to tail to check if some of its teammates (elements of the same team) are already in the queue. If yes, it enters the queue right behind them. If not, it enters the queue at the tail and becomes the new last element (bad luck). Dequeuing is done like in normal queues: elements are processed from head to tail in the order they appear in the team queue.

Your task is to write a program that simulates such a team queue.
 

 

 

Input

The input will contain one or more test cases. Each test case begins with the number of teams t (1<=t<=1000). Then t team descriptions follow, each one consisting of the number of elements belonging to the team and the elements themselves. Elements are integers in the range 0 - 999999. A team may consist of up to 1000 elements.

Finally, a list of commands follows. There are three different kinds of commands:

ENQUEUE x - enter element x into the team queue
DEQUEUE - process the first element and remove it from the queue
STOP - end of test case
The input will be terminated by a value of 0 for t.
 

 

 

Output

For each test case, first print a line saying "Scenario #k", where k is the number of the test case. Then, for each DEQUEUE command, print the element which is dequeued on a single line. Print a blank line after each test case, even after the last one.

 

 

Sample Input

 

2

3 101 102 103

3 201 202 203

ENQUEUE 101

ENQUEUE 201

ENQUEUE 102

ENQUEUE 202

ENQUEUE 103

ENQUEUE 203

DEQUEUE

DEQUEUE

DEQUEUE

DEQUEUE

DEQUEUE

DEQUEUE

STOP

2

5 259001 259002 259003 259004 259005

6 260001 260002 260003 260004 260005 260006

ENQUEUE 259001

ENQUEUE 260001

ENQUEUE 259002

ENQUEUE 259003

ENQUEUE 259004

ENQUEUE 259005

DEQUEUE

DEQUEUE

ENQUEUE 260002

ENQUEUE 260003

DEQUEUE

DEQUEUE

DEQUEUE

DEQUEUE

STOP

0

 

 

Sample Output

 

Scenario #1

101

102

103

201

202

203

Scenario #2

259001

259002

259003

259004

259005

 

解题思路是使用一个队列q存储队伍信息,在使用一个队列q1[100]存储每个队伍成员的信息

AC代码:
#include<cstdio>
#include<queue>
#include<map>
#include<algorithm>
#include<cstring>
using namespace std;
int main(void)
{
    int t, k, m, i;
    k = 0;
    while(scanf("%d", &t))//有几队 
    {
        if(t == 0)
        {
            break;
        }
        k++;
        printf("Scenario #%dn", k);
        map<int, int> io; 
        for(i = 0; i < t; i++)//使用map来解决无法存储某个人属于哪个队伍的问题 
        {
            scanf("%d", &m);//每个队伍有多少人 
            while(m--)
            {
                int x;
                scanf("%d", &x);
                io[x] = i;//使得每个属于同一个队伍的成员的map的second相同 
            }
        }
        queue<int> q, q1[1000];//q用来存储队伍,q1[i]用来存储每个队的成员 
        char s[109];
        while(scanf("%s", s))
        {
            if(strcmp(s, "STOP") == 0)
            {
                break;
            }
            if(strcmp(s, "ENQUEUE") == 0)
            {
                int en;
                scanf("%d", &en);
                int team = io[en];//获取队伍编号 
                if(q1[team].empty())//如果此队伍尚且没有成员,就把这个队伍压入q 
                {
                    q.push(team);
                }
                q1[team].push(en);//成员入队 
            }
            if(strcmp(s, "DEQUEUE") == 0)
            {
                int one = q.front();
                printf("%dn", q1[one].front());//成员输出 
                q1[one].pop();
                if(q1[one].empty())//如果当前队伍已空,则队伍出队 
                {
                    q.pop();
                }
            }
            
        }
        printf("n");
    }
    return 0;
}

 

 

 

最后

以上就是热情身影为你收集整理的集训笔记---队列应用(HDUOJ NO.1387 Team Queue )Team Queue的全部内容,希望文章能够帮你解决集训笔记---队列应用(HDUOJ NO.1387 Team Queue )Team Queue所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(33)

评论列表共有 0 条评论

立即
投稿
返回
顶部