我是靠谱客的博主 大胆向日葵,最近开发中收集的这篇文章主要介绍Large Division LightOJ - 1214(模运算,数论水题),觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Large Division

LightOJ - 1214


Given two integers, a and b, you should check whether a is divisible by b or not. We know that an integer a is divisible by an integer b if and only if there exists an integer c such that a = b * c.


Input

Input starts with an integer T (≤ 525), denoting the number of test cases.

Each case starts with a line containing two integers a (-10200 ≤ a ≤ 10200) and b (|b| > 0, b fits into a 32 bit signed integer). Numbers will not contain leading zeroes.

Output

For each case, print the case number first. Then print 'divisible' if a is divisible by b. Otherwise print 'not divisible'.

Sample Input

6

101 101

0 67

-101 101

7678123668327637674887634 101

11010000000000000000 256

-202202202202000202202202 -101

Sample Output

Case 1: divisible

Case 2: divisible

Case 3: divisible

Case 4: not divisible

Case 5: divisible

Case 6: divisible

比较水的一道题,直接a以字符串输入,转化成整数的时候每次模b,注意如果是负数都转成整数即可,因为能否整除和符号无关

code:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int main(){
    int t,cas = 0;
    scanf("%d",&t);
    while(t--){
        char a[250];
        long long b;
        scanf("%s%lld",a,&b);
        if(b < 0) b = -b;
        int i = 0;
        while(a[i] == '-') i++;
        long long ans = 0;
        for(; a[i]; i++){
            ans = (ans * 10 % b + a[i] - '0') % b;
        }
        if(!ans)
            printf("Case %d: divisiblen",++cas);
        else
            printf("Case %d: not divisiblen",++cas);
    }
    return 0;
}


最后

以上就是大胆向日葵为你收集整理的Large Division LightOJ - 1214(模运算,数论水题)的全部内容,希望文章能够帮你解决Large Division LightOJ - 1214(模运算,数论水题)所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(29)

评论列表共有 0 条评论

立即
投稿
返回
顶部