我是靠谱客的博主 阔达凉面,最近开发中收集的这篇文章主要介绍UVA Overflow(判断是否大于int的最大值)  Overflow  ,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Overflow
Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu
Submit  Status

Description

Download as PDF


 Overflow 

Write a program that reads an expression consisting of two non-negative integer and an operator. Determine if either integer or the result of the expression is too large to be represented as a ``normal'' signed integer (type integer if you are working Pascal, type int if you are working in C).

Input

An unspecified number of lines. Each line will contain an integer, one of the two operators + or *, and another integer.

Output

For each line of input, print the input followed by 0-3 lines containing as many of these three messages as are appropriate: ``first number too big'', ``second number too big'', ``result too big''.

Sample Input

300 + 3
9999999999999999999999 + 11

Sample Output

300 + 3
9999999999999999999999 + 11
first number too big
result too big
 
     
 
     
 
     
 
     
#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>

using namespace std;

int main()
{
    char aa[1000],bb[1100];
    double a,b,c;
    char ch;
    while(scanf("%s%*c%c%s",&aa,&ch,&bb)!=EOF)
    {
        int flag1 = 0;
        int flag2 = 0;
        int flag3 = 0;
        a = atof(aa);
        b = atof(bb);
        if(a>2147483647)
        {
            flag1 = 1;
        }
        if(b>2147483647)
        {
            flag2 = 1;
        }
        if(ch == '+')
        {
            c = a + b;
            if(c>2147483647)
            {
                flag3 = 1;
            }
        }
        else if(ch == '*')
        {
            c = a * b;
            if(c > 2147483647)
            {
                flag3 = 1;
            }
        }
        cout << aa << " " << ch << " " << bb << endl;
        if(flag1 == 1)
        {
            printf("first number too bign");
        }
        if(flag2 == 1)
        {
            printf("second number too bign");
        }
        if(flag3 == 1)
        {
            printf("result too bign");
        }
    }
    return 0;
}

最后

以上就是阔达凉面为你收集整理的UVA Overflow(判断是否大于int的最大值)  Overflow  的全部内容,希望文章能够帮你解决UVA Overflow(判断是否大于int的最大值)  Overflow  所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(43)

评论列表共有 0 条评论

立即
投稿
返回
顶部