概述
顺序表ADT模板设计及简单应用:将顺序表中前 m 个元素和后 n 个元素进行互换
作者: 冯向阳 时间限制: 1S 章节: DS:线性表
问题描述 :
目的:使用自行设计的顺序表ADT或STL中的vector模板,设计并实现顺序表应用场合的一些简单算法设计。
应用1:试设计一个算法,用尽可能少的辅助空间将非空顺序表中前 m 个元素和后 n 个元素进行互换,即将线性表(a1,a2,…,am,b1,b2,…,bn) 改变成(b1,b2,…,bn,a1,a2,…,am)。假定m始终是有效值。
参考函数原型:
(1)顺序表ADT版本
template
void Exchange( SqList &A, int m ); // 本算法实现顺序表中前 m 个元素和后 n 个元素的互换
(2)vector版本
template
void Exchange( vector &A, int m );// 本算法实现顺序表中前 m 个元素和后 n 个元素的互换
输入说明 :
第一行:顺序表的数据元素类型标记(0:int;1:double;2:char;3:string;其余值:输出err)
第二行:待处理顺序表的数据元素(数据元素之间以空格分隔)
第三行:逆置位置m
输出说明 :
第一行:逆置前顺序表的遍历结果(数据元素之间以“,”分隔)
空行
第三行:逆置后顺序表的遍历结果(数据元素之间以“,”分隔)
输入范例 :
0
13 5 27 9 32 123 76 98 54 87
5
输出范例 :
13,5,27,9,32,123,76,98,54,87
123,76,98,54,87,13,5,27,9,32
我写的是顺序表的版本
具体AC代码:
#include<iostream>
#include<cstdlib>
#include<cstdio>
#include<cstring>
using namespace std;
#define OK 1
#define ERROR 0
#define OVERFLOW -2
typedef int Status; //Status 是函数返回值类型,其值是函数结果状态代码。
const int MAXSIZE=100; //顺序表可能达到的最大长度
template<class ElemType>
class SqList
{
private:
ElemType *elem; // 存储空间基址
int length; // 当前长度
public:
//初始化顺序表
SqList();
SqList(ElemType a[],int n);
//析构顺序表
~SqList();
void Exchange( SqList<ElemType> &x, int m );
Status ListInsert_push(ElemType e);
//返回顺序表的长度
int GetLength()
{
return length;
}
};
template<class ElemType>
SqList<ElemType>::SqList()
{
//构造一个空的顺序表L
elem = new ElemType[MAXSIZE]; //为顺序表分配一个大小为MAXSIZE的数组空间
length = 0; //空表长度为0
}
template<class ElemType>
SqList<ElemType>::SqList(ElemType a[],int n)
{
// 本算法生成顺序表
elem = new ElemType[MAXSIZE]; //为顺序表分配一个大小为MAXSIZE的数组空间
for(int i = 0; i < n; i++)
{
elem[i]=a[i];
}
length=n;
}
template<class ElemType>
SqList<ElemType>::~SqList()
{
//销毁顺序表
//需要为SqList类实现拷贝构造函数和重载等于号,才可以在析构函数中delete顺序表,否则程序可能崩溃,因此这里暂时将delete语句注释掉了
//delete elem;
//length = 0;
}
template<class ElemType>
void SqList<ElemType>::Exchange( SqList<ElemType> &x, int m )
{
//前m个元素和后n个元素互换的函数
SqList<ElemType> a;
for(int i=0;i<m;i++)
{
a.elem[i] = x.elem[i];
a.length++;
}
for(int i=m;i<x.length;i++)
{
x.elem[i-m] = x.elem[i];
}
for(int i=x.length-m,j=0;i<x.length;i++,j++)
{
x.elem[i] = a.elem[j];
}
}
template<class ElemType>
Status SqList<ElemType>::ListInsert_push(ElemType e)
{
if (length == MAXSIZE)
return ERROR; //当前存储空间已满
if(length == 0)
elem[0] = e;
else
elem[length] = e; // 插入e
++ length; // 表长增1
return OK;
} // ListInsert_push
template<class ElemType>
void SqList<ElemType>::ListTraverse()
{
//打印顺序表
for(int i = 0; i < length-1; i++)
{
cout<<elem[i]<<",";
}
cout<<elem[length-1]<<endl;
}
int main()
{
int x;
int m;
cin>>x;
switch(x)
{
case 0:
{
int a;
int z[100];
int num=0;
while(1)
{
cin>>a;
z[num++] = a;
if(cin.get() == 'n')
break;
}
SqList<int> z0(z,num);
z0.ListTraverse();
cout<<endl;
cin >> m;
z0.Exchange(z0, m);
z0.ListTraverse();
break;
}
case 1:
{
double a;
double z[100];
int num=0;
while(1)
{
cin>>a;
z[num++] = a;
if(cin.get() == 'n')
break;
}
SqList<double> z1(z,num);
z1.ListTraverse();
cout<<endl;
cin >> m;
z1.Exchange(z1, m);
z1.ListTraverse();
break;
}
case 2:
{
char a;
char z[100];
int num=0;
while(1)
{
cin>>a;
z[num++] = a;
if(cin.get() == 'n')
break;
}
SqList<char> z2(z,num);
z2.ListTraverse();
cout<<endl;
cin >> m;
z2.Exchange(z2, m);
z2.ListTraverse();
break;
}
case 3:
{
string a;
string z[100];
int num=0;
while(1)
{
cin>>a;
z[num++] = a;
if(cin.get() == 'n')
break;
}
SqList<string> z3(z,num);
z3.ListTraverse();
cout<<endl;
cin >> m;
z3.Exchange(z3, m);
z3.ListTraverse();
break;
}
default:
cout<<"err"<<endl;
}
return 0;
}
是基于Turbo老师的代码改的
最后
以上就是紧张金针菇为你收集整理的顺序表ADT模板设计及简单应用:将顺序表中前 m 个元素和后 n 个元素进行互换的全部内容,希望文章能够帮你解决顺序表ADT模板设计及简单应用:将顺序表中前 m 个元素和后 n 个元素进行互换所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
发表评论 取消回复