我是靠谱客的博主 妩媚网络,最近开发中收集的这篇文章主要介绍integer f(n)(数论),觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

This time I need you to calculate the f(n) . (3<=n<=1000000)

f(n)= Gcd(3)+Gcd(4)+…+Gcd(i)+…+Gcd(n).

Gcd(n)=gcd(C[n][1],C[n][2],……,C[n][n-1])

C[n][k] means the number of way to choose k things from n some things.

gcd(a,b) means the greatest common divisor of a and b.
InputThere are several test case. For each test case:One integer n(3<=n<=1000000). The end of the in put file is EOF.OutputFor each test case:

The output consists of one line with one integer f(n).
Sample Input
3
26983
Sample Output
3
37556486
题意:这也是根据条件求解f[n],f(n)= Gcd(3)+Gcd(4)+…+Gcd(i)+…+Gcd(n). 看着这个条件,和对里面Gcd的解释挺复杂的。
解题思路:这都题,之前一直找不到方法,因为Gcd的求解有点复杂,然后通过观看大佬的博客才知道人家用打表找出了规律;
1.当n为素数时,那么Gcd[n]就为n本身;
2.当n有且只有一个素因子时,除了自己本身,那么Gcd[n]就为这个素因子,如4,4=2^2所就为2;
3.当n有多个素因子时,那么Gcd[n]就为1;
解题步骤
1)查找范围内的,素数和素数的某些倍数(只有这一个素因子),因为他们的Gcd的值都为这个素数,然后有其他有多个素因子的就为1;
2)让然后根据等式,储存所有的数;
3)然后根据输入,进行对应输出就行;

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
#define maxn 1000005
long long Gcd[maxn];
int main()
{
    int n;
    memset(Gcd,0,sizeof(Gcd));
    for(int i=2;i<=maxn;i++)
        {
            if(!Gcd[i])
                {
                    Gcd[i]=i;
                    for(int j=i*2;j<=maxn;j+=i)
                        {
                            if(!Gcd[j]) Gcd[j]=i;
                            else Gcd[j]=1;
                        }
                }
        }
    for(int i=4;i<=maxn;i++)
        Gcd[i]+=Gcd[i-1];
    while(scanf("%d",&n)!=EOF)
        {
            cout<<Gcd[n]<<endl;
        }
    return 0;
}

最后

以上就是妩媚网络为你收集整理的integer f(n)(数论)的全部内容,希望文章能够帮你解决integer f(n)(数论)所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(39)

评论列表共有 0 条评论

立即
投稿
返回
顶部