概述
求:3^0 + 3^1 +...+ 3^(N) mod 1000000007
Input
输入一个数N(0 <= N <= 10^9)
Output
输出:计算结果
Sample Input
3
Sample Output
40
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <algorithm>
#include <cmath>
#include <vector>
#include <queue>
#include <cstring>
using namespace std;
typedef long long ll;
const int maxn = 1e2 + 5;
const int INF = (1 << 30);
const double inf = 1e-6;
const int mod = 1e9 + 7;
const int MOD = 1e9 + 7;
int t, n, m, ans, cnt, cc;
int f[maxn], vis[maxn][maxn];
char mp[maxn][maxn];
struct node {
int x, y, steps;
} no[maxn];
ll FastPow(ll n, ll k) {
ll ans = 1;
while(k) {
if(k & 1) {
ans *= n;
ans %= mod;
}
k >>= 1;
n *= n;
n %= mod;
}
return ans;
}
int main() {
scanf("%d", &n);
ll a = (FastPow(3, n + 1) - 1 + mod) % mod;
ll b = (FastPow(2, mod - 2)) % mod;
printf("%lldn", (a * b) % mod);
return 0;
}
最后
以上就是谦让紫菜为你收集整理的A - 费马小定理的全部内容,希望文章能够帮你解决A - 费马小定理所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
发表评论 取消回复