我是靠谱客的博主 优美泥猴桃,最近开发中收集的这篇文章主要介绍The Unique MST poj 1679(次小生成树),觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

题目:POJ - 1679 

Given a connected undirected graph, tell if its minimum spanning tree is unique. 

Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V', E'), with the following properties: 
1. V' = V. 
2. T is connected and acyclic. 

Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E') of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all the edges in E'. 

Input

The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.

Output

For each input, if the MST is unique, print the total cost of it, or otherwise print the string 'Not Unique!'.

Sample Input

2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2

Sample Output

3
Not Unique!

 

本题在询问你该生成树,是否与其他树相同。

我们利用次小生成树,求出次小生成树,记录的在求次小生成树过程中的边,求完之后,加入一条边就会像成一个环,然后就减去以前的一条边,肯定不能是新加入的边,这样最后判断,两次求出的结果是否相同,如果相同,就输出"not"否则输出长度。

可以参考这个:传送门;

次小生成树:求最小生成树的时候,用数组Max[i][j]来表示MST中从i到j最大边权,求完后,直接枚举所有不在MST中的边,替换掉最大边权的边,更新答案,点的编号从0开始。

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
const int maxn
= 110;
const int INF = 0x3f3f3f3f;
bool vis[maxn];
int pre[maxn];
int lowc[maxn];
int Max[maxn][maxn];//Max[i][j]表示在最小生成树中从i到j的路径中的最大边权。
bool used[maxn][maxn];
int cost[maxn][maxn];
int Prim(int n)
{
int ans = 0;
memset(vis,false,sizeof vis);
memset(Max,0,sizeof Max);
memset(used,false,sizeof used);
vis[0] = true;
pre[0] = -1;
for(int i = 1;i < n;i ++)
{
lowc[i] = cost[0][i];
pre[i] = 0;
}
lowc[0] = 0;
for(int i = 1;i < n;i ++)
{
int minc = INF;
int p = -1;
for(int
j = 0;j < n;j ++)
if(!vis[j]&&minc > lowc[j])
{
minc = lowc[j];
p = j;
}
if(minc == INF) return -1;
ans += minc;
vis[p] = true;
used[p][pre[p]] = used[pre[p]][p] =true;
for(int j = 0;j < n;j ++)
{
if(vis[j]&&j != p)Max[j][p] = Max[p][j] =max(Max[j][pre[p]],lowc[p]);
if(!vis[j]&&lowc[j] > cost[p][j]){
lowc[j] = cost[p][j];
pre[j] = p;
}
}
}
return ans;
}
int ans;
int MST(int n)
{
int MIN
= INF;
for(int i = 0;i < n;i ++)
for(int j = i + 1;j < n;j ++)
{
if(cost[i][j] != INF&&!used[i][j])
MIN = min(MIN,ans + cost[i][j] - Max[i][j]);
}
if(MIN == INF) return -1;
else return MIN;
}
int main()
{
int n,m;
int t;
scanf("%d",&t);
while(t --)
{
scanf("%d%d",&n,&m);
int u,v,w;
for(int i = 0;i < n;i ++)
for(int j = 0;j < n;j ++)
{
if(i == j)cost[i][i] = 0;
else cost[i][j] = INF;
}
for(int i = 0;i < m;i ++)
{
scanf("%d%d%d",&u,&v,&w);
cost[u - 1][v - 1] = cost[v - 1][u - 1] = w;
}
ans = Prim(n);
if(ans == -1){
puts("Not Unique!");
continue;
}
if(ans == MST(n))puts("Not Unique!");
else printf("%dn",ans);
}
return 0;
}

 

最后

以上就是优美泥猴桃为你收集整理的The Unique MST poj 1679(次小生成树)的全部内容,希望文章能够帮你解决The Unique MST poj 1679(次小生成树)所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(30)

评论列表共有 0 条评论

立即
投稿
返回
顶部