概述
Time Limit: 3000MS | Memory Limit: Unknown | 64bit IO Format: %lld & %llu |
Description
Given an undirected weighted graph G , you should find one of spanning trees specified as follows.
The graph G is an ordered pair (V, E) , where V is a set of vertices {v1, v2,..., vn} and E is a set of undirected edges {e1, e2,..., em} . Each edgeeE has its weight w(e) .
A spanning tree T is a tree (a connected subgraph without cycles) which connects all the n vertices with n - 1 edges. The slimness of a spanning tree T is defined as the difference between the largest weight and the smallest weight among the n - 1 edges of T .
For example, a graph G in Figure 5(a) has four vertices {v1, v2, v3, v4} and five undirected edges {e1, e2, e3, e4, e5} . The weights of the edges are w(e1) = 3 , w(e2) = 5 , w(e3) = 6 , w(e4) = 6 , w(e5) = 7 as shown in Figure 5(b).
There are several spanning trees for G . Four of them are depicted in Figure 6(a)∼(d). The spanning tree Ta in Figure 6(a) has three edges whose weights are 3, 6 and 7. The largest weight is 7 and the smallest weight is 3 so that the slimness of the tree Ta is 4. The slimnesses of spanning trees Tb , Tc and Td shown in Figure 6(b), (c) and (d) are 3, 2 and 1, respectively. You can easily see the slimness of any other spanning tree is greater than or equal to 1, thus the spanning tree Td in Figure 6(d) is one of the slimmest spanning trees whose slimness is 1.
Your job is to write a program that computes the smallest slimness.
Input
The input consists of multiple datasets, followed by a line containing two zeros separated by a space. Each dataset has the following format.
nm
a1b1w1
ambmwm
Every input item in a dataset is a non-negative integer. Items in a line are separated by a space.
n is the number of the vertices and m the number of the edges. You can assume 2n100 and 0mn(n - 1)/2 . ak and bk(k = 1,..., m) are positive integers less than or equal to n , which represent the two vertices vak and vbk connected by the k -th edge ek . wk is a positive integer less than or equal to 10000, which indicates the weight of ek . You can assume that the graph G = (V, E) is simple, that is, there are no self-loops (that connect the same vertex) nor parallel edges (that are two or more edges whose both ends are the same two vertices).
Output
For each dataset, if the graph has spanning trees, the smallest slimness among them should be printed. Otherwise, `-1' should be printed. An output should not contain extra characters.
Sample Input
4 5 1 2 3 1 3 5 1 4 6 2 4 6 3 4 7 4 6 1 2 10 1 3 100 1 4 90 2 3 20 2 4 80 3 4 40 2 1 1 2 1 3 0 3 1 1 2 1 3 3 1 2 2 2 3 5 1 3 6 5 10 1 2 110 1 3 120 1 4 130 1 5 120 2 3 110 2 4 120 2 5 130 3 4 120 3 5 110 4 5 120 5 10 1 2 9384 1 3 887 1 4 2778 1 5 6916 2 3 7794 2 4 8336 2 5 5387 3 4 493 3 5 6650 4 5 1422 5 8 1 2 1 2 3 100 3 4 100 4 5 100 1 5 50 2 5 50 3 5 50 4 1 150 0 0
Sample Output
1 20 0 -1 -1 1 0 1686 50
<pre name="code" class="cpp">#include <stdio.h>
#include <string.h>
#include <math.h>
#include <algorithm>
#include <iostream>
using namespace std;
/*
这是一个最小生成树问题,我的Kruskal算法和并查集有部分模板
而且掌握的较好,所以用Kruskal;
从最小的边开始找最小生成树,然后去掉这个最小的边再找一个最小生成树
min1来储存最小的值,最后输出
*/
const int maxn=110;
struct aa
{
int x,y,l;
};
bool cmp(aa a,aa b)
{
return a.l<b.l;
};
aa a[maxn*55];
int fa[110],n;
int find(int a)
{
return fa[a]==a?a:find(fa[a]);
}
int haha(int i,int m)//处理
{
int rank=1,k=i,c,d;
for(; i<m; i++)
{
c=find(a[i].x);
d=find(a[i].y);
if(c!=d)
{
fa[c]=d;
rank++;
if(rank==n)return a[i].l-a[k].l;
}
}
return -1;
}
int main()
{
int m;
while(~scanf("%d%d",&n,&m))
{
if(m==0&&n==0)break;
memset(a,0,sizeof(a));
for(int i=0; i<n; i++)
fa[i]=i;
for(int i=0; i<m; i++)
{
scanf("%d%d%d",&a[i].x,&a[i].y,&a[i].l);
a[i].x--;
a[i].y--;
}
sort(a,a+m,cmp);
int min1=-1;
for(int i=0; i<m; i++)
{
int k=haha(i,m);
if(k!=-1)
{
if(min1==-1)min1=k;
else
min1=min(min1,k);
}
for(int i=0; i<n; i++)
fa[i]=i;
}
printf("%dn",min1);
}
return 0;
}
最后
以上就是大胆画笔为你收集整理的Kruskal模板题 Slim Span uva的全部内容,希望文章能够帮你解决Kruskal模板题 Slim Span uva所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
发表评论 取消回复