概述
Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input
The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output
For each case, output the number of suspects in one line.
Sample Input
100 4 2 1 2 5 10 13 11 12 14 2 0 1 2 99 2 200 2 1 5 5 1 2 3 4 5 1 0 0 0
Sample Output
4 1 1
题意: 有n个人,m组,接下来给出每组人的编号(从0开始),已知与0号人在一组的会得某种传染病,这种传染病会传播,如果小组内有一人得病,整个组都会得病,询问最终得病人数。
分析: 得病关系会间接传播,因此考虑到使用并查集。对于每组内成员,直接合并为一个集合,因为最终要统计与0号人在一个集合的人数,每次合并时可以取编号较小的人作为祖先,这样只要与0号人在一个集合,它们的祖先一定是0,最终遍历一遍输出祖先为0的人数。
具体代码如下:
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
int fa[30005], n, m;
int find(int x)
{
if(x == fa[x])
return x;
return fa[x] = find(fa[x]);
}
signed main()
{
while(cin >> n >> m)
{
if(n == 0 && m == 0)
break;
for(int i = 0; i < n; i++)
fa[i] = i;
for(int i = 1; i <= m; i++)
{
int num;
scanf("%d", &num);
if(num == 0)
continue;
int start;
scanf("%d", &start);
for(int j = 2; j <= num; j++)
{
int t;
scanf("%d", &t);
if(find(start) != find(t))
fa[max(find(start), find(t))] = min(find(start), find(t));
}
}
int ans = 0;
for(int i = 0; i < n; i++)
if(find(i) == 0)
ans++;
printf("%dn", ans);
}
return 0;
}
最后
以上就是淡淡柜子为你收集整理的[并查集]The Suspects POJ1611的全部内容,希望文章能够帮你解决[并查集]The Suspects POJ1611所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
发表评论 取消回复