概述
1019 General Palindromic Number
A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.
Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N>0 in base b≥2, where it is written in standard notation with k+1 digits ai as ∑i=0k(aibi). Here, as usual, 0≤ai<b for all i and ak is non-zero. Then N is palindromic if and only if ai=ak−i for all i. Zero is written 0 in any base and is also palindromic by definition.
Given any positive decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.
Input Specification:
Each input file contains one test case. Each case consists of two positive numbers N and b, where 0<N≤109 is the decimal number and 2≤b≤109 is the base. The numbers are separated by a space.
Output Specification:
For each test case, first print in one line Yes
if N is a palindromic number in base b, or No
if not. Then in the next line, print N as the number in base b in the form "ak ak−1 ... a0". Notice that there must be no extra space at the end of output.
Sample Input 1:
27 2
Sample Output 1:
Yes
1 1 0 1 1
Sample Input 2:
121 5
Sample Output 2:
No
4 4 1
自己写的代码:
这里直接用了int 类型的sum来存储转换后的值,会存在爆int的可能,比如:n=5000,b=2,这样会超过int的表示范围,还是用数组来存储比较好!
(2022.11.1)这样的代码如果遇到基数超过10的就会发生错误,入 19 20 在20进制下,结果19其实就是一个一位的数字,但这个代码会判断为两位数,最终发生错误
#include <iostream>
#include <algorithm>
using namespace std;
int sum;
void convert(int n,int x){
if(n<=0) return;
int u=n%x;
convert(n/x,x);
sum=sum*10+u;
}
int main(){
int n,b;
cin >> n >> b;
convert(n,b);
cout << sum << endl;
string t=to_string(sum);
string w;
for(int i=t.size()-1;i>=0;i--){
w+=t[i];
}
if(w==t) puts("Yes");
else puts("No");
for(int i=0;i<w.size();i++){
printf("%d",w[i]);
if(i!=w.size()-1) printf(" ");
}
return 0;
}
学习到的小技巧:
将数字转化成任意进制的数:
int arr[40];//这里足够大,防止爆int
while(a){
arr[index++]=a%b;
a/=b;
}
大佬的代码:
例子:
a=18 b=20;
这样的例子对结果是不会有影响的,由于a!=0,所以index=1,不会执行中间的循环,所以后面flag肯定执行打印 yes
#include <cstdio>
using namespace std;
int main() {
int a, b;
scanf("%d %d", &a, &b);
int arr[40], index = 0;
while(a != 0) {
arr[index++] = a % b;
a = a / b;
}
int flag = 0;
for(int i = 0; i < index / 2; i++) {
if(arr[i] != arr[index-i-1]) {//index-1表示最后一个数字,在-i表示偏移量
printf("Non");
flag = 1;
break;
}
}
if(!flag) printf("Yesn");
for(int i = index - 1; i >= 0; i--) {
printf("%d", arr[i]);
if(i != 0) printf(" ");
}
if(index == 0)
printf("0");
return 0;
}
2022.11.1(第二次写)
//思路:先将取余得到的每一个数字存进数组中,为什么需要存进数组中呢,因为如果
//基址b超出了10,那么会遇到取余后的一个数字是一个两位数,为了方便比较转化成b
//进制后的结果判断是否是一个回文数字,所以使用数组存放取余的结果
#include <iostream>
using namespace std;
int a[50000];
bool judge(int t){
for(int i=0;i<t/2;i++)
if(a[i]!=a[t-i-1]) return false;
return true;
}
int main(){
int n,b;
scanf("%d%d",&n,&b);
int index=0;
for(int i=0;n;i++){
a[index++]=n%b;
n/=b;
}
if(judge(index)) puts("Yes");
else puts("No");
printf("%d",a[index-1]);
for(int i=index-2;i>=0;i--) printf(" %d",a[i]);
return 0;
}
好好学习,天天向上!
我要考研!
最后
以上就是爱撒娇小伙为你收集整理的PAT 1019 General Palindromic Number的全部内容,希望文章能够帮你解决PAT 1019 General Palindromic Number所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
发表评论 取消回复