我是靠谱客的博主 落寞凉面,最近开发中收集的这篇文章主要介绍杭电ACM2052java做法,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Picture

Problem Description
Give you the width and height of the rectangle,darw it.

Input
Input contains a number of test cases.For each case ,there are two numbers n and m (0 < n,m < 75)indicate the width and height of the rectangle.Iuput ends of EOF.

Output
For each case,you should draw a rectangle with the width and height giving in the input.
after each case, you should a blank line. 

Sample Input
3 2

Sample Output
+---+
|   |
|   |

+---+


感觉这道题比较水吧,我没想啥好办法,就直接打了


import java.util.Scanner;
public class Main {
public static void main(String[] args){
Scanner scanner=new Scanner(System.in);
while(scanner.hasNextInt()){
int a=scanner.nextInt();
int b=scanner.nextInt();
for(int i=0;i<b+2;i++){
if(i==0||i==b+1){
System.out.print("+");
for(int j=1;j<a+1;j++){
System.out.print("-");
}
System.out.println("+");
}
else{
System.out.print("|");
for(int j=1;j<a+1;j++){
System.out.print(" ");
}
System.out.println("|");
}
}
System.out.println();
}
}
}


最后

以上就是落寞凉面为你收集整理的杭电ACM2052java做法的全部内容,希望文章能够帮你解决杭电ACM2052java做法所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(39)

评论列表共有 0 条评论

立即
投稿
返回
顶部