我是靠谱客的博主 甜美鸵鸟,最近开发中收集的这篇文章主要介绍hdu4864(贪心),觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Today the company has m tasks to complete. The ith task need xi minutes to complete. Meanwhile, this task has a difficulty level yi. The machine whose level below this task’s level yi cannot complete this task. If the company completes this task, they will get (500*xi+2*yi) dollars.
The company has n machines. Each machine has a maximum working time and a level. If the time for the task is more than the maximum working time of the machine, the machine can not complete this task. Each machine can only complete a task one day. Each task can only be completed by one machine.
The company hopes to maximize the number of the tasks which they can complete today. If there are multiple solutions, they hopes to make the money maximum.

Input
The input contains several test cases.
The first line contains two integers N and M. N is the number of the machines.M is the number of tasks(1 < =N <= 100000,1<=M<=100000).
The following N lines each contains two integers xi(0<xi<1440),yi(0=<yi<=100).xi is the maximum time the machine can work.yi is the level of the machine.
The following M lines each contains two integers xi(0<xi<1440),yi(0=<yi<=100).xi is the time we need to complete the task.yi is the level of the task.
Output
For each test case, output two integers, the maximum number of the tasks which the company can complete today and the money they will get.
Sample Input
1 2
100 3
100 2
100 1
Sample Output
1 50004


/*按照权重推算的结果是在排序时工作时间大小顺序优先,时间相等时等级高的优先。贪心策略为:对于每个任务让机器的工作时间和等级最接近的去完成即可*/
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>

using namespace std;

struct node{
    int time, l;
    bool operator < (const node & a) const{
        if(time == a.time) return l > a.l;
        else
            return time > a.time;
    }
}M[100100], t[100100];
int vis[200];

int main()
{
    int n, m;
    while(scanf("%d%d", &n,&m) != EOF){
        memset(vis, 0, sizeof(vis));
        for(int i = 0; i < n; i++) scanf("%d%d", &M[i].time, &M[i].l);
        for(int i = 0; i < m; i++) scanf("%d%d", &t[i].time, &t[i].l);
        sort(M, M + n);
        sort(t, t + m);
        int j = 0;
        int cnt = 0;
        long long sum = 0;
        for(int i = 0; i < m; i++){
            while(j < n && M[j].time >= t[i].time){    //这里是贪心的核心让机器的工作时间和等级最接济任务的工作和时间去匹配
                vis[M[j].l]++;
                j++;
            }
            for(int k = t[i].l; k <= 100; k++){
                if(vis[k] > 0){
                    cnt++;
                    vis[k]--;
                    sum = sum + (500 * t[i].time + 2 * t[i].l);
                    break;
                }
            }
        }
        printf("%d %lldn", cnt, sum);    //这里要注意lld输出不然wa
    }
    return 0;
}


最后

以上就是甜美鸵鸟为你收集整理的hdu4864(贪心)的全部内容,希望文章能够帮你解决hdu4864(贪心)所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(53)

评论列表共有 0 条评论

立即
投稿
返回
顶部