概述
题干
Milking Cows
Three farmers rise at 5 am each morning and head for the barn to milk three cows. The first farmer begins milking his cow at time 300 (measured in seconds after 5 am) and ends at time 1000. The second farmer begins at time 700 and ends at time 1200. The third farmer begins at time 1500 and ends at time 2100. The longest continuous time during which at least one farmer was milking a cow was 900 seconds (from 300 to 1200). The longest time no milking was done, between the beginning and the ending of all milking, was 300 seconds (1500 minus 1200).
Your job is to write a program that will examine a list of beginning and ending times for N (1 <= N <= 5000) farmers milking N cows and compute (in seconds):
- The longest time interval at least one cow was milked.
- The longest time interval (after milking starts) during which no cows were being milked.
NOTE: Milking from time 1 through 10, then from time 11 through 20 counts as two different time intervals.
PROGRAM NAME: milk2
INPUT FORMAT
Line 1: | The single integer, N |
Lines 2..N+1: | Two non-negative integers less than 1,000,000, respectively the starting and ending time in seconds after 0500 |
SAMPLE INPUT (file milk2.in)
3
300 1000
700 1200
1500 2100
OUTPUT FORMAT
A single line with two integers that represent the longest continuous time of milking and the longest idle time.
SAMPLE OUTPUT (file milk2.out)
900 300
思路
我们读取时间列表,按开始时间排序,然后遍历列表一次,合并重叠时间。然后我们遍历列表,观察长时间的挤奶期和长时间的非挤奶期。
另一种方法是只保留一个大小为一百万的数组并标记时间。在一个不错的快速处理器上,这可能已经足够快了,但是我们上面的算法即使在慢速处理器上也能工作,而且编写起来并不难。
解题
/*
ID: choiyin1
LANG: C++
PROG: milk2
*/
#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
int cmp(int a,int b){
return a<=b;
}
int main(){
// freopen("milk2.in","r",stdin);
// freopen("milk2.out","w",stdout);
int n;
cin>>n;
int begin[6000];
int end[6000];
begin[0]=0;
end[0]=0;
for(int i=1;i<=n;i++){
scanf("%d %d",&begin[i],&end[i]);
}
sort(begin,begin+n+1,cmp);
sort(end,end+n+1,cmp);
begin[0]=begin[1];
end[0]=end[1];
sort(begin,begin+n+1,cmp);
sort(end,end+n+1,cmp);
int have[6000];
int havent[6000];
for(int i=1;i<=n;i++){
have[i]=0;
}
for(int i=1;i<=n;i++){
havent[i]=0;
}
for(int i=1;i<=n;i++){
if(end[i-1]>=begin[i]){
begin[i]=begin[i-1];
}
have[i]=end[i]-begin[i];
}
for(int i=1;i<=n;i++){
havent[i]=begin[i]-end[i-1];
}
sort(have,have+n+1,cmp);
sort(havent,havent+n+1,cmp);
if(havent[n]<0){
havent[n]=0;
}
cout<<have[n]<<" "<<havent[n]<<endl;
return 0;
}
最后
以上就是活泼铃铛为你收集整理的USACO Training 1.3 Milking Cows的全部内容,希望文章能够帮你解决USACO Training 1.3 Milking Cows所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
发表评论 取消回复