概述
D Pairs Description Given N integers, count the number of pairs of integers whose sum is less than K. And we have M queries.
Input The first behavior is an integer T (1 < = T < = 10), on behalf of the number of sets of data. Each group of data is the first line N, M (1 < = n, m < = 100000), The next line will give N integers. a[i] (0<=a[i]<=100000). The next M lines, each line contains the query K (1 <= K<=200000).
Output For each query, output the number of pairs of integers whose sum is less than K.
Sample Input:
1
5 2
1 5 3 4 2
5
7
Sample Output:
2
6
题意:给你一个长度为n的数组,m次提问,问两个数和小于k的集合的个数。
题解:
比赛时感觉挺简单。然后就蒙了,不就是维护一个和的有序表,判断一下就好了啊,就是超时。。。。。看了标称才知道,得用FFT来加速这个维护的过程。get新东西。
代码:
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <math.h>
#include <stdlib.h>
#include <time.h>
using namespace std;
const double PI = acos(-1.0);
struct complex
{
double r,i;
complex(double _r = 0,double _i = 0)
{
r = _r; i = _i;
}
complex operator +(const complex &b)
{
return complex(r+b.r,i+b.i);
}
complex operator -(const complex &b)
{
return complex(r-b.r,i-b.i);
}
complex operator *(const complex &b)
{
return complex(r*b.r-i*b.i,r*b.i+i*b.r);
}
};
void change(complex y[],int len)
{
int i,j,k;
for(i = 1, j = len/2;i < len-1;i++)
{
if(i < j)swap(y[i],y[j]);
k = len/2;
while( j >= k)
{
j -= k;
k /= 2;
}
if(j < k)j += k;
}
}
void fft(complex y[],int len,int on)
{
change(y,len);
for(int h = 2;h <= len;h <<= 1)
{
complex wn(cos(-on*2*PI/h),sin(-on*2*PI/h));
for(int j = 0;j < len;j += h)
{
complex w(1,0);
for(int k = j;k < j+h/2;k++)
{
complex u = y[k];
complex t = w*y[k+h/2];
y[k] = u+t;
y[k+h/2] = u-t;
w = w*wn;
}
}
}
if(on == -1)
for(int i = 0;i < len;i++)
y[i].r /= len;
}
const int MAXN = 400040;
complex x1[MAXN];
int a[MAXN/4];
long long num[MAXN];//100000*100000会超int
long long sum[MAXN];
int main()
{
int T;
int n;
int m;
scanf("%d",&T);
while(T--)
{
scanf("%d%d",&n, &m);
memset(num,0,sizeof(num));
for(int i = 0;i < n;i++)
{
scanf("%d",&a[i]);
num[a[i]]++;
}
sort(a,a+n);
int len1 = a[n-1]+1;
int len = 1;
while( len < 2*len1 )len <<= 1;
for(int i = 0;i < len1;i++)
x1[i] = complex(num[i],0);
for(int i = len1;i < len;i++)
x1[i] = complex(0,0);
fft(x1,len,1);
for(int i = 0;i < len;i++)
x1[i] = x1[i]*x1[i];
fft(x1,len,-1);
for(int i = 0;i < len;i++)
num[i] = (long long)(x1[i].r+0.5);
len = 2*a[n-1];
//减掉取两个相同的组合
for(int i = 0;i < n;i++)
num[a[i]+a[i]]--;
//选择的无序,除以2
for(int i = 1;i <= len;i++)
{
num[i]/=2;
num[i] += num[i-1];
}
while(m--) {
int k;
scanf("%d", &k);
printf("%lldn", num[k-1]);
}
}
return 0;
}
最后
以上就是开心大树为你收集整理的D Pairs(FFT)的全部内容,希望文章能够帮你解决D Pairs(FFT)所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
发表评论 取消回复