我是靠谱客的博主 可爱水蜜桃,最近开发中收集的这篇文章主要介绍1096 A+B for Input-Output Practice (VIII),觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Problem

Description Your task is to calculate the sum of some integers.

Input

Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.

Output

For each group of input integers you should output their sum in one line, and you must note that there is a blank line between outputs.

Sample Input

3
4 1 2 3 4
5 1 2 3 4 5
3 1 2 3

Sample Output

10

15

6

解题过程

#include <stdio.h>
int main()
{
int n,num,x,i,m,a;
scanf("%d",&n);
a=n;
for(i=0;i<n;i++,a--)
{
scanf("%d",&m);
num=0;
while(m--)
{
scanf("%d",&x);
num+=x;
}
printf("%dn",num);
if(a!=1||a<1)
{
putchar('n');
}
}
return 0;
}

解题总结

做这个题要注意细节,按照题的意思做题,我的问题主要是在输出的格式上存在着问题,是在换行上卡住了,要看仔细题的输出样式,这是我根据我的解法进行的解决办法:if(a!=1||a<1) { putchar('n'); } },方法有多种,要多理解题。
注:题号1096

心得感受

对于题目要一丝不苟,不要加入“我觉得是这样”的思想,就像我的老师告诉我的:程序就像女朋友,不要试图和程序讲道理。要更多的把注意放在题目上。加油!!!

最后

以上就是可爱水蜜桃为你收集整理的1096 A+B for Input-Output Practice (VIII)的全部内容,希望文章能够帮你解决1096 A+B for Input-Output Practice (VIII)所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(43)

评论列表共有 0 条评论

立即
投稿
返回
顶部