我是靠谱客的博主 着急白昼,最近开发中收集的这篇文章主要介绍(hdu step 8.1.2)Train Problem I(站的基本应用——判断一个序列经过栈后是否能够得到第二个序列)Train Problem I,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

题目:

Train Problem I

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 78 Accepted Submission(s): 60
 
Problem Description
As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can\\\'t leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.
 
Input
The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.
 
Output

            The output contains a string \\\"No.\\\" if you can\\\'t exchange O2 to O1, or you should output a line contains \\\"Yes.\\\", and then output your way in exchanging the order(you should output \\\"in\\\" for a train getting into the railway, and \\\"out\\\" for a train getting out of the railway). Print a line contains \\\"FINISH\\\" after each test case. More details in the Sample Output.
 
Sample Input
3 123 321
3 123 312
 
Sample Output
Yes.
in
in
in
out
out
out
FINISH
No.
FINISH


      
      
Hint
Hint
For the first Sample Input, we let train 1 get in, then train 2 and train 3. So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1. In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3. Now we can let train 3 leave. But after that we can\\\'t let train 1 leave before train 2, because train 2 is at the top of the railway at the moment. So we output \\\"No.\\\".
 
Author
Ignatius.L


题目分析:

             站的应用,简单题。



代码如下:

/*
 * b1.cpp
 *
 *  Created on: 2015年3月19日
 *      Author: Administrator
 */


#include <iostream>
#include <cstdio>
#include <stack>

using namespace std;

const int maxn = 101;


int main(){
	int n;//序列的元素个数
	string str1;//第一个序列
	string str2;//第二个序列
	int result[maxn];//用于标记进出栈情况

	while(cin >> n >> str1 >> str2){

		stack<char> st;


		int i = 0;//用于标记第一个序列目前比较到哪里了
		int j = 0;//用于标记第二个序列目前比较到哪里了
		int k;
		st.push(str1[0]);//现将第一个序列的第一个元素进栈
		result[0] = true;
		k = 1;

		while(i < n && j < n){//当序列还没有比较完
			//如果栈非空 && 栈顶元素和第二个序列目前比较到的元素相同
			if((st.empty() == false) && (st.top() == str2[j]) ){
				j++;//将第二个序列的索引向后移动一位
				st.pop();//栈顶元素出栈
				result[k++] = false;//标记元素的进出情况
			}else{
				//如果栈已经为空 || 栈顶元素不等于第二个序列中目前匹配到的元素

				if(i == n){//如果第一个元素的所有元素已经入过栈
					break;//跳出循环
				}
				//否则第一个序列中还有元素没有入栈

				st.push(str1[++i]);//降低一个序列的下一个元素入展
				result[k++] = true;//标记进出情况
			}
		}


		//输出结果
		if(i == n){
			cout << "No." << endl;
		}else{
			cout << "Yes." << endl;

			for(i = 0 ; i < k ; ++i){
				if(result[i] == true){
					cout << "in" << endl;
				}else{
					cout << "out" << endl;
				}
			}
		}

		cout << "FINISH" << endl;
	}

	return 0;
}




最后

以上就是着急白昼为你收集整理的(hdu step 8.1.2)Train Problem I(站的基本应用——判断一个序列经过栈后是否能够得到第二个序列)Train Problem I的全部内容,希望文章能够帮你解决(hdu step 8.1.2)Train Problem I(站的基本应用——判断一个序列经过栈后是否能够得到第二个序列)Train Problem I所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(38)

评论列表共有 0 条评论

立即
投稿
返回
顶部