我是靠谱客的博主 想人陪烧鹅,最近开发中收集的这篇文章主要介绍字符串练习18_验证子串,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

/*
Name: 18_验证子串
Copyright:
Author:
Date: 01-09-17 22:06
Description: 18_验证子串
查看 提交 统计 提问
总时间限制: 1000ms 内存限制: 65536kB
描述
输入两个字符串,验证其中一个串是否为另一个串的子串。
输入
输入两个字符串,每个字符串占一行,长度不超过200且不含空格。
输出
若第一个串s1是第二个串s2的子串,则输出(s1) is substring of (s2)
否则,若第二个串s2是第一个串s1的子串,输出(s2) is substring of (s1)
否则,输出 No substring。
样例输入
abc
dddncabca
样例输出
abc is substring of dddncabca
*/
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int N = 201;
char S1[N],S2[N];
int main()
{
gets(S1); gets(S2);
if (strlen(S1) >= strlen(S2))
{
if (strstr(S1, S2) != NULL)
cout << S2 << " is substring of " << S1 << endl;
else
cout << "No substring" << endl;
}
else
{
if (strstr(S2, S1) != NULL)
cout << S1 << " is substring of " << S2 << endl;
else
cout << "No substring" << endl;
}
return 0;
} 

最后

以上就是想人陪烧鹅为你收集整理的字符串练习18_验证子串的全部内容,希望文章能够帮你解决字符串练习18_验证子串所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(39)

评论列表共有 0 条评论

立即
投稿
返回
顶部