概述
InterGames is a high-tech startup company that specializes in developing technology that allows users to play games over the Internet. A market analysis has alerted them to the fact that games of chance are pretty popular among their potential customers. Be it Monopoly, ludo or backgammon, most of these games involve throwing dice at some stage of the game.
Of course, it would be unreasonable if players were allowed to throw their dice and then enter the result into the computer, since cheating would be way to easy. So, instead, InterGames has decided to supply their users with a camera that takes a picture of the thrown dice, analyzes the picture and then transmits the outcome of the throw automatically.
For this they desperately need a program that, given an image containing several dice, determines the numbers of dots on the dice.
We make the following assumptions about the input images. The images contain only three dif- ferent pixel values: for the background, the dice and the dots on the dice. We consider two pixelsconnected if they share an edge - meeting at a corner is not enough. In the figure, pixels A and B are connected, but B and C are not.
A set S of pixels is connected if for every pair (a,b) of pixels inS, there is a sequence inS such thata = a1 and b = ak , andai andai+1 are connected for.
We consider all maximally connected sets consisting solely of non-background pixels to be dice. `Maximally connected' means that you cannot add any other non-background pixels to the set without making it dis-connected. Likewise we consider every maximal connected set of dot pixels to form a dot.
Input
The input consists of pictures of several dice throws. Each picture description starts with a line containing two numbers w and h, the width and height of the picture, respectively. These values satisfy .The following h lines contain w characters each. The characters can be: ``.'' for a background pixel, ``*'' for a pixel of a die, and ``X'' for a pixel of a die's dot.
Dice may have different sizes and not be entirely square due to optical distortion. The picture will contain at least one die, and the numbers of dots per die is between 1 and 6, inclusive.
The input is terminated by a picture starting with w = h = 0, which should not be processed.
Output
For each throw of dice, first output its number. Then output the number of dots on the dice in the picture, sorted in increasing order.Print a blank line after each test case.
Sample Input
30 15 .............................. .............................. ...............*.............. ...*****......****............ ...*X***.....**X***........... ...*****....***X**............ ...***X*.....****............. ...*****.......*.............. .............................. ........***........******..... .......**X****.....*X**X*..... ......*******......******..... .....****X**.......*X**X*..... ........***........******..... .............................. 0 0
Sample Output
Throw 1 1 2 2 4
#include <iostream>
#include <string>
#include <cstdio>
#include <cstring>
#include <algorithm>
#define N 1000
using namespace std;
int w, h;
char a[N][N];
int co[N][N];
int vi[N][N];
int b[N];
int cmp (const void *a,const void *b)
{
return *(int *)a - *(int *)b;
}
//寻找含有X的区域有几个;
void dfs(int x,int y, int c) {
if (x >= w || x < 0 || y >= h || y < 0 || a[x][y] == '.' || co[x][y])
return ;
co[x][y] = c;
dfs(x+1,y,c);dfs(x-1,y,c);
dfs(x,y+1,c);dfs(x,y-1,c);
}
//进行搜索相邻的X,
void bfs(int x,int y)
{
if(x >= w || x < 0 || y >=h || y < 0 ||vi[x][y] )
return ;
if(a[x][y] == 'X')
{
vi[x][y] = 1;
bfs(x+1,y);bfs(x-1,y);
bfs(x,y-1);bfs(x,y+1);
}
}
int main(){
int Case = 0;
while (scanf("%d%d",&h,&w) != EOF) {
if (w == 0 && h == 0)
break;
++Case;
printf("Throw %dn",Case);
for(int i = 0; i < w; i++)
scanf("%s",a[i]);
memset(co,0,sizeof(0));
int k= 0;
for(int i = 0; i < w; i++)
for(int
j = 0; j < h; j++)
{
if(a[i][j] != '.' && co[i][j] == 0)
{
++k;
dfs(i,j,k);
}
}
memset(b,0,sizeof(b));
memset(vi,0,sizeof(vi));
for(int i = 0 ; i < w; i++)
for(int j = 0; j < h; j++)
{
if(a[i][j] == 'X' && vi[i][j] == 0)
{
bfs(i,j);
b[co[i][j] - 1] ++;
}
}
qsort(b, k, sizeof(int),cmp);
int i;
for( i = 0; i < k -1 ;i++)
printf("%d ",b[i]);
if(i == k- 1)
printf("%dnn",b[i]);//最后一个不可以有空格而且每一个测试数据之后都需要换行
}
return 0;
}
最后
以上就是传统自行车为你收集整理的UVA - 657 The die is cast的全部内容,希望文章能够帮你解决UVA - 657 The die is cast所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
发表评论 取消回复